summaryrefslogtreecommitdiff
path: root/gdk/meson.build
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2017-11-22 10:44:30 +0100
committerBenjamin Otte <otte@redhat.com>2017-12-03 05:46:27 +0100
commit91910ba01319447243784a85fefad0fa17c19db7 (patch)
treecf9410387bc20b6f01457f7c421041ccdb1e43bf /gdk/meson.build
parent970cb100aff72679b15c3c8b27b168335d0e5a50 (diff)
downloadgtk+-91910ba01319447243784a85fefad0fa17c19db7.tar.gz
gdk: Im[plement content deserializing
Add infrastructure to do GInputStream => GType conversions. Use that to implement gdk_clipboard_read_value() which reads into GValues.
Diffstat (limited to 'gdk/meson.build')
-rw-r--r--gdk/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/gdk/meson.build b/gdk/meson.build
index d1e75ce5b2..88045c38c6 100644
--- a/gdk/meson.build
+++ b/gdk/meson.build
@@ -3,6 +3,7 @@ gdk_public_sources = files([
'gdkapplaunchcontext.c',
'gdkcairo.c',
'gdkclipboard.c',
+ 'gdkcontentdeserializer.c',
'gdkcontentformats.c',
'gdkcursor.c',
'gdkdevice.c',
@@ -43,6 +44,7 @@ gdk_public_headers = files([
'gdkapplaunchcontext.h',
'gdkcairo.h',
'gdkclipboard.h',
+ 'gdkcontentdeserializer.h',
'gdkcontentformats.h',
'gdkcursor.h',
'gdkdevice.h',