summaryrefslogtreecommitdiff
path: root/gdk/broadway/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2013-11-07 12:22:38 +0100
committerAlexander Larsson <alexl@redhat.com>2013-11-07 14:09:53 +0100
commit5ef114ba425fe636c611840b58a5fb8e0962e1f2 (patch)
tree28e62e34cd23aa8f0fb311b474eea493fd656677 /gdk/broadway/Makefile.am
parentbbfe7e0e697fdc9e5921eeaba013843218594f94 (diff)
downloadgtk+-5ef114ba425fe636c611840b58a5fb8e0962e1f2.tar.gz
Switch from sending png frames to our own encoding
This is based on the rolling hashes code from http://cgit.freedesktop.org/~krh/weston/log/?h=remote It works by incrementally calculating hashes for every 32x32 block in each frame sent, and then refering back to such blocks when encoding the next frame. This means we detect when a block matches an existing block in the previous frame in a different position. This is great for detecting scrolling, which we need now that the gdk level scrolling is neutered.
Diffstat (limited to 'gdk/broadway/Makefile.am')
-rw-r--r--gdk/broadway/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gdk/broadway/Makefile.am b/gdk/broadway/Makefile.am
index ec482e98c4..e48e09eaab 100644
--- a/gdk/broadway/Makefile.am
+++ b/gdk/broadway/Makefile.am
@@ -83,6 +83,8 @@ broadwayd_SOURCES = \
broadwayd.c \
broadway-server.h \
broadway-server.c \
+ broadway-buffer.c \
+ broadway-buffer.h \
broadway-output.h \
broadway-output.c