summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-07-09 00:10:12 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-07-09 00:10:12 +0000
commitc0dace5fd9deb9197415ba7c994f392acdfde0ea (patch)
tree14ae690ab3aeab5bdaa9b3da054f8a8b5f37dc6c /gdk/Makefile.am
parent13d49dd3d1981591554262b46e3ab633dd64db75 (diff)
downloadgtk+-c0dace5fd9deb9197415ba7c994f392acdfde0ea.tar.gz
Look for windres on Win32.
2005-07-09 Tor Lillqvist <tml@novell.com> * configure.in: Look for windres on Win32. * gdk-pixbuf/Makefile.am * gdk/win32/rc/Makefile.am * gdk/Makefile.am * gtk/Makefile.am: Don't use the scripts in build/win32 to compile the rc files into resource object files. (This means we lose the build number increment magic, but I doubt it was that useful anyway.) Instead use windres directly. To pass a normal .o file produced by windres through libtool, which would want a .lo file, pass it directly to the linker using a -Wl option. * gdk-pixbuf/gdk_pixbuf.rc.in * gdk/win32/rc/gdk.rc.in * gtk/gtk-win32.rc.in: Replace BUILDNUMBER with 0.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index b7beef37ed..0c1d650c03 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -147,8 +147,8 @@ libgdk_linux_fb_2_0_la_LDFLAGS = $(LDADD)
libgdk_win32_2_0_la_SOURCES = $(common_sources) gdkkeynames.c
libgdk_win32_2_0_la_LIBADD = win32/libgdk-win32.la $(GDK_DEP_LIBS) \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la
-libgdk_win32_2_0_la_DEPENDENCIES = win32/libgdk-win32.la gdk.def
-libgdk_win32_2_0_la_LDFLAGS = -export-symbols gdk.def $(LDADD)
+libgdk_win32_2_0_la_DEPENDENCIES = win32/libgdk-win32.la win32/rc/gdk-win32-res.o gdk.def
+libgdk_win32_2_0_la_LDFLAGS = -Wl,win32/rc/gdk-win32-res.o -export-symbols gdk.def $(LDADD)
if HAVE_WINTAB
libgdk_win32_2_0_la_LIBADD += -Lwin32 -lwntab32x
endif