summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-08-17 18:24:06 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-08-17 18:24:06 +0000
commit54fb7a7b0d8761a0f5e38d94b35cfbaac4695d1f (patch)
tree75aae9b46fef1ac234624c133258d3fb6019e529 /gdk/Makefile.am
parent3cc0ae605a10eb7f24bc6083e2388a7103a4aeb4 (diff)
downloadgtk+-54fb7a7b0d8761a0f5e38d94b35cfbaac4695d1f.tar.gz
No need for INCLUDE_INTERNAL_SYMBOLS anymore.
2004-08-17 Matthias Clasen <mclasen@redhat.com> * gtk/abicheck.sh: No need for INCLUDE_INTERNAL_SYMBOLS anymore. * gdk/gdk.symbols: Don't use #if defined(). * gdk/Makefile.am (gdkalias.h): * gtk/Makefile.am (gtkalias.h): Don't use cpp to filter gtk.symbols. * gdk/makegdkalias.pl: * gtk/makegtkalias.pl: Move the #ifdef processing into the perl script, and keep the #ifdefs which differentiate between platforms. * gtk/Makefile.am (gtk_private_h_sources): Remove gtkinternals.h, it is no longer needed.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index fbf7ba481a..c8578a00fc 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -180,7 +180,7 @@ gdk.def: gdk.symbols
(echo -e EXPORTS; cpp -P -DGDK_WINDOWING_WIN32 -DINCLUDE_VARIABLES gdk.symbols | sed -e '/^$$/d' -e 's/^/\t/') > gdk.def
gdkalias.h: gdk.symbols
- cpp -P gdk.symbols -DGDK_WINDOWING_X11 | ./makegdkalias.pl > gdkalias.h
+ ./makegdkalias.pl <gdk.symbols > gdkalias.h
if OS_UNIX
TESTS = abicheck.sh