summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorCEST 2000 Paolo Molaro <lupus@linuxcare.com>2000-06-07 16:44:29 +0000
committerPaolo Molaro <lupus@src.gnome.org>2000-06-07 16:44:29 +0000
commit4bacc3ecd070f63d13fd2994595cc1b175f91f1e (patch)
treeac68f7f9deacf66f41d30f234805eae22f41bb02 /gdk/Makefile.am
parent544b6cb26e036adc12a2110c82edb0574a9431b4 (diff)
downloadgtk+-4bacc3ecd070f63d13fd2994595cc1b175f91f1e.tar.gz
make it possible to configure gtk for different targets on the same
Mon Jun 5 19:32:53 CEST 2000 Paolo Molaro <lupus@linuxcare.com> * configure.in, gtk-config.in, gdk/Makefile.am, gdk/*/Makefile.am, gtk/Makefile.am: make it possible to configure gtk for different targets on the same platform. The library name is now libgtk-$target-$version.so. gtk-config accepts a --target x11|nanox|linux-fb flag. Only the x11 target compiles right now. * gdk/gdkregion-generic.h, gdk/gdkregion-generic.c, gdk/gdkpoly-generic.h, gdk/gdkpolyreg-generic.c: move generic region code in the main GDK dir. * gdk/nanox/gdk*generic*: delete generic region code. * gdk/linux-fb/gdk*generic*: delete generic region code. * README.nanox: update information.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am68
1 files changed, 52 insertions, 16 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 1936d9c552..722453088b 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for gtk+/gdk
-SUBDIRS=x11 win32
+SUBDIRS=x11 win32 nanox linux-fb
EXTRA_DIST = \
gdkconfig.h.win32 \
@@ -8,7 +8,7 @@ EXTRA_DIST = \
makefile.cygwin \
makefile.msc
-INCLUDES = @STRIP_BEGIN@ \
+common_includes = @STRIP_BEGIN@ \
-DG_LOG_DOMAIN=\"Gdk\" \
-I$(top_srcdir) \
-I$(top_builddir)/gdk \
@@ -17,30 +17,27 @@ INCLUDES = @STRIP_BEGIN@ \
@GTK_LOCALE_FLAGS@ \
@PANGO_CFLAGS@ \
@GLIB_CFLAGS@ \
- @x_cflags@ \
+ @more_cflags@ \
@STRIP_END@
-#
-# libraries to compile and install
-#
-lib_LTLIBRARIES = libgdk.la
+INCLUDES = $(common_includes)
+gtarget=@gdktarget@
# libtool stuff: set version and export symbols for resolving
-libgdkincludedir = $(includedir)/gdk
-libgdk_la_LDFLAGS = @STRIP_BEGIN@ \
+# since automake doesn't support conditionalized libsomething_la_LDFLAGS
+# we use the general approach here
+LDFLAGS = @STRIP_BEGIN@ \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-release $(LT_RELEASE) \
-export-dynamic \
+ -rpath @prefix@/lib \
@PANGO_LIBS@ \
@GLIB_DEPLIBS@ \
- @x_ldflags@ \
- @x_libs@ \
+ @more_ldflags@ \
+ @more_libs@ \
-lm \
@STRIP_END@
-libgdk_la_LIBADD = \
- x11/libgdk-x11.la
-
#
# setup source file variables
#
@@ -90,16 +87,55 @@ gdk_c_sources = @STRIP_BEGIN@ \
gdkimage.c \
gdkinternals.h \
gdkpango.c \
+ gdkpoly-generic.h \
+ gdkpolyreg-generic.c \
gdkrgb.c \
gdkrectangle.c \
+ gdkregion-generic.c \
+ gdkregion-generic.h \
gdkwindow.c \
@STRIP_END@
#
# setup GDK sources and their dependancies
#
-libgdkinclude_HEADERS = $(gdk_public_h_sources)
-libgdk_la_SOURCES = $(gdk_c_sources)
+extra = @gdktargetlib@
+
+if USE_X11
+libgdk_x11_includedir = $(includedir)/gdk
+
+libgdk_x11_la_LIBADD = \
+ $(gtarget)/libgdk-$(gtarget).la
+
+libgdk_x11_include_HEADERS = $(gdk_public_h_sources)
+libgdk_x11_la_SOURCES = $(gdk_c_sources)
+endif
+
+if USE_NANOX
+libgdk_nanox_includedir = $(includedir)/gdk
+
+libgdk_nanox_la_LIBADD = \
+ $(gtarget)/libgdk-$(gtarget).la
+
+libgdk_nanox_include_HEADERS = $(gdk_public_h_sources)
+libgdk_nanox_la_SOURCES = $(gdk_c_sources)
+endif
+
+if USE_LINUX_FB
+libgdk_linux_fb_includedir = $(includedir)/gdk
+
+libgdk_linux_fb_la_LIBADD = \
+ $(gtarget)/libgdk-$(gtarget).la
+
+libgdk_linux_fb_include_HEADERS = $(gdk_public_h_sources)
+libgdk_linux_fb_la_SOURCES = $(gdk_c_sources)
+endif
+
+# now define the real one to workaround automake's mishandling
+lib_LTLIBRARIES = $(extra)
+
+EXTRA_LTLIBRARIES = libgdk-x11.la libgdk-nanox.la libgdk-linux-fb.la
+
MAINTAINERCLEANFILES +=
EXTRA_HEADERS +=
EXTRA_DIST +=