summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-01-03 10:45:37 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-01-03 11:59:45 -0500
commitcacee7e7a380ac9009fc1339a860f563ebe4dc4d (patch)
tree17e127046551f6187434eba5e27f99307f376524 /gdk/Makefile.am
parentae7e5fc2d19445ba55832888adcc7c24aeb17323 (diff)
downloadgtk+-cacee7e7a380ac9009fc1339a860f563ebe4dc4d.tar.gz
configure.ac: Support multiple GDK backends in one build
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 4d3a92ea5e..c28a07f51a 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -8,7 +8,8 @@ INTROSPECTION_COMPILER_ARGS = \
--includedir=$(srcdir) \
--includedir=.
-SUBDIRS = $(gdktarget) . tests
+SUBDIRS = $(GDK_BACKENDS) . tests
+
DIST_SUBDIRS = win32 x11 quartz tests
CLEANFILES =
@@ -38,8 +39,6 @@ INCLUDES = \
$(GTK_DEBUG_FLAGS) \
$(GDK_DEP_CFLAGS)
-gtarget=$(gdktarget)
-
if PLATFORM_WIN32
no_undefined = -no-undefined
endif