summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-12-18 15:38:49 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-02-05 16:11:54 -0500
commit590f3dfa1fcb812e4c334f574c6bb0431b131d04 (patch)
tree8cc912daf60928b0dd532a0172d4bedbcfdc96cf /gdk/Makefile.am
parentbfaf472e703a5378fe8e6b59e116e28dea7ccace (diff)
downloadgtk+-590f3dfa1fcb812e4c334f574c6bb0431b131d04.tar.gz
Add Wayland backend
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index f81147e062..91fcbb0531 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -11,7 +11,7 @@ INTROSPECTION_COMPILER_ARGS = \
SUBDIRS = $(GDK_BACKENDS) . tests
-DIST_SUBDIRS = win32 x11 quartz tests
+DIST_SUBDIRS = win32 x11 quartz wayland tests
CLEANFILES =
@@ -176,6 +176,10 @@ libgdk_3_0_la_DEPENDENCIES = win32/libgdk-win32.la win32/rc/gdk-win32-res.o gdk.
libgdk_3_0_la_LDFLAGS += -Wl,win32/rc/gdk-win32-res.o -export-symbols $(srcdir)/gdk.def
endif # USE_WIN32
+if USE_WAYLAND
+libgdk_3_0_la_LIBADD += wayland/libgdk-wayland.la
+endif
+
if HAVE_INTROSPECTION
introspection_files = \