summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-12-11 00:14:53 -0500
committerMatthias Clasen <mclasen@redhat.com>2010-12-21 12:06:58 -0500
commitea96e5e16f964c71f2ac3fcf5237542e4776221c (patch)
treef2c524c44208396157bfe0141c9f6a811c9e059d /gdk/Makefile.am
parentff8a334725e95fda2e0c500b55955e1cd311bf98 (diff)
downloadgtk+-ea96e5e16f964c71f2ac3fcf5237542e4776221c.tar.gz
Explode gdkinternals.h into per-class private headers
At the same time, move some more class and instance structs out of public headers.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 801719d9ac..3413076249 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -96,9 +96,18 @@ gdk_built_public_sources = \
gdkenumtypes.h
gdk_private_headers = \
- gdkinternals.h \
+ gdkapplaunchcontextprivate.h \
+ gdkdevicemanagerprivate.h \
gdkdeviceprivate.h \
- gdkintl.h
+ gdkdisplaymanagerprivate.h \
+ gdkdisplayprivate.h \
+ gdkdndprivate.h \
+ gdkscreenprivate.h \
+ gdkinternals.h \
+ gdkintl.h \
+ gdkkeysprivate.h \
+ gdkvisualprivate.h \
+ gdkpoly-generic.h
gdk_c_sources = \
gdk.c \