summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2012-10-05 16:46:36 +0200
committerBenjamin Otte <otte@redhat.com>2012-10-06 15:55:30 -0400
commitdd3c56d783644d2ea597f761fa95047514d10cb8 (patch)
treeb8bd62f31faebee9cb60835695aa11c20a4e8acf /gdk/Makefile.am
parent1a1361c4b335299384031fa2daee4215a145f07e (diff)
downloadgtk+-dd3c56d783644d2ea597f761fa95047514d10cb8.tar.gz
gdk: Ignore headers for declared functions
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index b6b74ce1e8..8c811b589a 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -341,7 +341,8 @@ gdkmarshalers.h: @REBUILD@ gdkmarshalers.list
&& mv gdkmarshalers-h.tmp gdkmarshalers.h \
|| ( rm -f gdkmarshalers-h.tmp && exit 1)
gdkmarshalers.c: @REBUILD@ gdkmarshalers.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_gdk_marshal $(srcdir)/gdkmarshalers.list --body > gdkmarshalers-c.tmp \
+ $(AM_V_GEN) (echo "#include \"gdkmarshalers.h\""; \
+ $(GLIB_GENMARSHAL) --prefix=_gdk_marshal $(srcdir)/gdkmarshalers.list --body) > gdkmarshalers-c.tmp \
&& mv gdkmarshalers-c.tmp gdkmarshalers.c \
|| ( rm -f gdkmarshalers-c.tmp && exit 1 )