summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-09-08 13:35:51 -0400
committerColin Walters <walters@verbum.org>2010-09-08 18:51:44 -0400
commit913cdf3be750a1e74c09b20edf55a57f9a919fcc (patch)
tree0d2129a167579c0d896bb9213503619b2ef44d1f /gdk/Makefile.am
parent03c19e37af1f7aa9af8a48bcc9dc023397f8693f (diff)
downloadgtk+-913cdf3be750a1e74c09b20edf55a57f9a919fcc.tar.gz
GDK: Prefix key names with KEY_
The keysyms create a lot of potential namespace conflicts for C, and are especially problematic for introspection, where we take constants into the namespace, so GDK_Display conflicts with GdkDisplay. For C application compatiblity, add gdkkeysyms-compat.h which uses the old names. Just one user in GTK+ continues to use gdkkeysyms-compat.h, which is the gtkimcontextsimple.c, since porting that requires porting more custom Perl code.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 9247570cd5..39242cf374 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -84,6 +84,7 @@ gdk_public_h_sources = \
gdkinput.h \
gdkkeys.h \
gdkkeysyms.h \
+ gdkkeysyms-compat.h \
gdkpango.h \
gdkpixbuf.h \
gdkpixmap.h \
@@ -171,7 +172,7 @@ libgdk_win32_3_0_la_LDFLAGS = -Wl,win32/rc/gdk-win32-res.o -export-symbols $(src
if HAVE_INTROSPECTION
introspection_files = \
- $(gdk_public_h_sources) \
+ $(filter-out gdkkeysyms-compat.h, $(gdk_public_h_sources)) \
$(gdk_c_sources) \
gdkenumtypes.c \
gdkenumtypes.h