summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-08-01 15:28:40 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-08-01 15:28:40 +0000
commite5ae081ebea69057c9e9da5175869b87b0972ed0 (patch)
treee6be8246d4b84e8cfbe2c859de97683065211344 /gdk/Makefile.am
parentd202b55bc05460d36b759de33b93cfea0f9870c7 (diff)
downloadgtk+-e5ae081ebea69057c9e9da5175869b87b0972ed0.tar.gz
Start implementing display/screen closing scheme; keep a flag for whether
Thu Aug 1 11:26:03 2002 Owen Taylor <otaylor@redhat.com> * gdk/gdkdisplay.[ch] gdk/gdkscreen.[ch] gdkinternals.h: Start implementing display/screen closing scheme; keep a flag for whether displays and screens are closed, call g_object_run_dispose(). Remove public gdk_screen_close(). * gdk/x11/gdkdisplay-x11.c gdk/x11/gdkscreen-x11.c: Add dispose() methods; move appropriate parts of the finalize there. * gdk/x11/gdkcolor-x11.c gdk/x11/gdkimage-x11.c gdk/x11/gdkmain-x11.c gdk/x11/gdkpango-x11.c gdk/x11/gdkpixmap-x11.c gdk/x11/gdkproperty-x11.c gdk/x11/gdkselection-x11.c gdk/x11/gdkwindow-x11.c: Start of making everything correctly ignore operations when a display has been closed. * gdk/x11/gdkwindow-x11.c (gdk_window_get_decorations): Handle decorations == NULL. * gdk/x11/gdkcolor-x11.c (gdk_colormap_remove): Remove unnecessary hash table creation. * gdk/x11/gdkinput.c gdk/x11/gdkinput-x11.c gdk/win32/gdkinput.c Fix up gdk_device_get_history - handle events, n_events == NULL, etc. * gdk/x11/gdkproperty-x11.c (gdk_property_get): Handle failure better. * gdk/x11/gdkselection-x11.c (gdk_selection_property_get): Handle failure better, handle data == NULL, move docs here, remove an excess round trip by asking for all selection data at once. * gdk/gdkselection.c gdk/win32/{x11,win32}/gdkselection-{x11,win32}.c gdk/{x11,win32}/gdkmain-{x11,win32}.c gdk/gdkdisplay.c: Move gdk_text_property_to_text_list(), gdk_string_to_compound_text(), gdk_display_set_sm_client_id() to display-independent part of GDK. * gdk/Makefile.am (gdk_c_sources): Sort gdkdisplay/screen.[ch] into the right place.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 8881a31244..62ae6275bd 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -91,6 +91,7 @@ gdk_public_h_sources = @STRIP_BEGIN@ \
gdk.h \
gdkcolor.h \
gdkcursor.h \
+ gdkdisplay.h \
gdkdnd.h \
gdkdrawable.h \
gdkevents.h \
@@ -108,12 +109,11 @@ gdk_public_h_sources = @STRIP_BEGIN@ \
gdkproperty.h \
gdkregion.h \
gdkrgb.h \
+ gdkscreen.h \
gdkselection.h \
gdktypes.h \
gdkvisual.h \
gdkwindow.h \
- gdkdisplay.h \
- gdkscreen.h \
@STRIP_END@
gdk_headers = @STRIP_BEGIN@ \
@@ -126,6 +126,7 @@ gdk_c_sources = @STRIP_BEGIN@ \
gdk.c \
gdkcolor.c \
gdkcursor.c \
+ gdkdisplay.c \
gdkdraw.c \
gdkevents.c \
gdkfont.c \
@@ -147,11 +148,10 @@ gdk_c_sources = @STRIP_BEGIN@ \
gdkrectangle.c \
gdkregion-generic.c \
gdkregion-generic.h \
+ gdkscreen.c \
gdkselection.c \
gdkvisual.c \
gdkwindow.c \
- gdkdisplay.c \
- gdkscreen.c \
@STRIP_END@
#