summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2016-11-21 14:18:43 +0100
committerBenjamin Otte <otte@redhat.com>2016-12-09 18:35:51 +0100
commitcca547e5bccda95fd8bf283bec1bfc7b564e88f6 (patch)
tree826a443ec9a14f02187471dc5c895966ceccf469 /gdk/Makefile.am
parent843fe3eec1eac94e278af2be165f26fe95ae6126 (diff)
downloadgtk+-cca547e5bccda95fd8bf283bec1bfc7b564e88f6.tar.gz
vulkan: Initial support
Adds the gdk_display_ref_vulkan() and gdk_display_unref_vulkan() functions which setup/tear down VUlkan support for the display. Nothing is using those functions yet.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 08d40a6647..7b69289171 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -91,6 +91,7 @@ gdk_public_h_sources = \
gdkthreads.h \
gdktypes.h \
gdkvisual.h \
+ gdkvulkancontext.h \
gdkwindow.h
gdk_h_sources = \
@@ -120,6 +121,7 @@ gdk_private_headers = \
gdkintl.h \
gdkkeysprivate.h \
gdkvisualprivate.h \
+ gdkvulkancontextprivate.h \
gdkx.h
gdk_c_sources = \
@@ -157,6 +159,7 @@ gdk_c_sources = \
gdkseatdefault.c \
gdkselection.c \
gdkvisual.c \
+ gdkvulkancontext.c \
gdkwindow.c \
gdkwindowimpl.c