summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2016-08-04 19:12:57 +0200
committerCarlos Garnacho <carlosg@gnome.org>2016-08-23 21:01:44 +0200
commitb8a77d4da310556014b06cf34cca2e9592da63fd (patch)
tree5a749f9f66471bccdcb8942e3b48bd750f0c0f40 /gdk/Makefile.am
parentf1a9cd466e48243ff6a3592b933bab2336e8c04d (diff)
downloadgtk+-b8a77d4da310556014b06cf34cca2e9592da63fd.tar.gz
gdk: Add GdkDevicePad
This is an interface meant to be implemented by the "pad" devices. This device-specific interface exposes the mapping of all pad features, it allows retrieving: - The number of buttons/rings/strips - The number of groups - The number of modes a group has - Whether a given button/ring/strip belongs to a given group https://bugzilla.gnome.org/show_bug.cgi?id=770026
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 684c7aba0a..052d4876d3 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -71,6 +71,7 @@ gdk_public_h_sources = \
gdkcairo.h \
gdkcursor.h \
gdkdevice.h \
+ gdkdevicepad.h \
gdkdevicetool.h \
gdkdevicemanager.h \
gdkdisplay.h \
@@ -114,6 +115,7 @@ gdk_private_headers = \
gdkcursorprivate.h \
gdkdevicemanagerprivate.h \
gdkdeviceprivate.h \
+ gdkdevicepadprivate.h \
gdkdevicetoolprivate.h \
gdkdisplaymanagerprivate.h \
gdkdisplayprivate.h \
@@ -144,6 +146,7 @@ gdk_c_sources = \
gdkcursor.c \
gdkdeprecated.c \
gdkdevice.c \
+ gdkdevicepad.c \
gdkdevicetool.c \
gdkdevicemanager.c \
gdkdisplay.c \