summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-09-17 09:23:30 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-09-17 09:49:19 -0400
commita3fa516c60bb0afc828b4fb35baf6aff98802a85 (patch)
treea245ff34d826f26185db155518aee64e1eb8dd2a /gdk/Makefile.am
parent27970efd52c3b9d4825cd10a81585ff3fabd4bef (diff)
downloadgtk+-a3fa516c60bb0afc828b4fb35baf6aff98802a85.tar.gz
Scan gdk/x11 sources for Gdk-3.0.gir
The doc comments (with annotations) for some of the gdk api are down in x11/ sources, so we need to scan those too, when building Gdk-3.0.gir.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 493feda378..c8b210248f 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -244,6 +244,9 @@ GdkX11_2_0_gir_LIBS = $(gdktargetlib)
GdkX11_2_0_gir_FILES = $(x11_introspection_files)
GdkX11_2_0_gir_CFLAGS = $(INCLUDES) -L$(top_builddir)/gdk
INTROSPECTION_GIRS += GdkX11-2.0.gir
+
+introspection_files += $(filter-out x11/gdkx.h, $(x11_introspection_files))
+
endif # USE_X11
girdir = $(datadir)/gir-1.0