summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-09-17 09:23:30 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-09-17 09:23:30 -0400
commitbf19aa46e9d846337ef2627e8a574a06cf4a54b8 (patch)
tree332c58cb8fb2ec4242cc719b162d41f85f04281c /gdk/Makefile.am
parent6aa8941b849e194d88b050a9737d2c0b13a6b562 (diff)
downloadgtk+-bf19aa46e9d846337ef2627e8a574a06cf4a54b8.tar.gz
Scan gdk/x11 sources for Gdk-3.0.gir
The doc comments (with annotations) for some of the gdk api are down in x11/ sources, so we need to scan those too, when building Gdk-3.0.gir.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index dca2456d2d..3417729c50 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -232,6 +232,9 @@ GdkX11_3_0_gir_LIBS = $(gdktargetlib)
GdkX11_3_0_gir_FILES = $(x11_introspection_files)
GdkX11_3_0_gir_CFLAGS = $(INCLUDES) -L$(top_builddir)/gdk
INTROSPECTION_GIRS += GdkX11-3.0.gir
+
+introspection_files += $(filter-out x11/gdkx.h, $(x11_introspection_files))
+
endif # USE_X11
girdir = $(datadir)/gir-1.0