summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2012-04-05 23:00:36 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2012-05-03 11:55:11 +0800
commit4f56f53ad7df6d7a8db7a6e6aca3bec283d74fdb (patch)
tree7cced39c29098cd1925e35996c9ce5665e337d13 /gdk/Makefile.am
parentc97f0b660c094d005844c0357df9bbc67c03861e (diff)
downloadgtk+-4f56f53ad7df6d7a8db7a6e6aca3bec283d74fdb.tar.gz
Bug 670499-Add gdk/fallback-c89.c
Add a fallback-c89.c for the gdk/ subdirectory as there is code that uses functions that are introduced by C99. This currently adds fallback implementations for MSVC for isnan() and isinf() Dist this "new" source file as well
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index c0760f2fd6..b6b74ce1e8 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -306,7 +306,9 @@ endif
lib_LTLIBRARIES = libgdk-3.la
MAINTAINERCLEANFILES = $(gdk_built_sources) stamp-gdkenumtypes.h
-EXTRA_DIST += $(gdk_built_sources)
+EXTRA_DIST += \
+ $(gdk_built_sources) \
+ fallback-c89.c
install-exec-hook:
if DISABLE_EXPLICIT_DEPS