summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2013-05-09 18:57:34 +0200
committerBenjamin Otte <otte@redhat.com>2013-05-09 19:09:50 +0200
commitecaf09c9185e2a364ac61865c39c506c6f0e6232 (patch)
tree9e295403fe637c0c14493c667b35c9bf344941ee /gdk/Makefile.am
parenta8da29b8dbc6241584780e9017ff30cbe50e26d9 (diff)
downloadgtk+-ecaf09c9185e2a364ac61865c39c506c6f0e6232.tar.gz
build: remove --disable-rebuilds
It's unused and was only useful when perl wasn't installed. But perl is a dependency of glib these days, so it's useless.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 38a39ec381..af0ac94450 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -315,13 +315,13 @@ BUILT_SOURCES = \
gdkenumtypes.h: stamp-gdkenumtypes.h
@true
-stamp-gdkenumtypes.h: @REBUILD@ $(gdk_public_h_sources) gdkenumtypes.h.template
+stamp-gdkenumtypes.h: $(gdk_public_h_sources) gdkenumtypes.h.template
$(AM_V_GEN) ( cd $(srcdir) && $(GLIB_MKENUMS) --template gdkenumtypes.h.template \
$(gdk_public_h_sources) ) >> xgen-geth \
&& (cmp -s xgen-geth gdkenumtypes.h || cp xgen-geth gdkenumtypes.h ) \
&& rm -f xgen-geth \
&& echo timestamp > $(@F)
-gdkenumtypes.c: @REBUILD@ $(gdk_public_h_sources) gdkenumtypes.c.template
+gdkenumtypes.c: $(gdk_public_h_sources) gdkenumtypes.c.template
$(AM_V_GEN) ( cd $(srcdir) && $(GLIB_MKENUMS) --template gdkenumtypes.c.template \
$(gdk_public_h_sources) ) > xgen-getc \
&& cp xgen-getc gdkenumtypes.c \
@@ -330,11 +330,11 @@ gdkenumtypes.c: @REBUILD@ $(gdk_public_h_sources) gdkenumtypes.c.template
#
# Marshaller generation
#
-gdkmarshalers.h: @REBUILD@ gdkmarshalers.list
+gdkmarshalers.h: gdkmarshalers.list
$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_gdk_marshal $(srcdir)/gdkmarshalers.list --header > gdkmarshalers-h.tmp \
&& mv gdkmarshalers-h.tmp gdkmarshalers.h \
|| ( rm -f gdkmarshalers-h.tmp && exit 1)
-gdkmarshalers.c: @REBUILD@ gdkmarshalers.list
+gdkmarshalers.c: gdkmarshalers.list
$(AM_V_GEN) (echo "#include \"gdkmarshalers.h\""; \
$(GLIB_GENMARSHAL) --prefix=_gdk_marshal $(srcdir)/gdkmarshalers.list --body) > gdkmarshalers-c.tmp \
&& mv gdkmarshalers-c.tmp gdkmarshalers.c \