summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2014-06-03 17:00:02 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2014-06-03 17:00:02 +0800
commitdd4bc9fd09dd2578cdf35746429b80af9b8a88cb (patch)
treef000b194c1ded061a0e3cd861ff05a32e98ffc55 /gdk/Makefile.am
parentddc3f8eae7872f8a0aa02c04ad1f915f33fa01c8 (diff)
downloadgtk+-dd4bc9fd09dd2578cdf35746429b80af9b8a88cb.tar.gz
gdk/Makefile.am: Fix MSVC Project Generation
We need to account for the sources that moved to gdk/deprecated/, so the slashes must be converted here.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index c9fd11d0bb..6adaa7ac5c 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -426,7 +426,7 @@ stamp-gc-h: $(top_builddir)/config.status
dist-hook: ../build/win32/vs9/gdk.vcproj ../build/win32/vs10/gdk.vcxproj ../build/win32/vs10/gdk.vcxproj.filters
../build/win32/vs9/gdk.vcproj: ../build/win32/vs9/gdk.vcprojin
- for F in $(libgdk_3_la_SOURCES); do \
+ for F in `echo $(libgdk_3_la_SOURCES) | tr '/' '\\'`; do \
case $$F in \
*.c) echo ' <File RelativePath="..\..\..\gdk\'$$F'" />' \
;; \
@@ -436,7 +436,7 @@ dist-hook: ../build/win32/vs9/gdk.vcproj ../build/win32/vs10/gdk.vcxproj ../buil
rm libgdk.sourcefiles
../build/win32/vs10/gdk.vcxproj: ../build/win32/vs10/gdk.vcxprojin
- for F in $(libgdk_3_la_SOURCES); do \
+ for F in `echo $(libgdk_3_la_SOURCES) | tr '/' '\\'`; do \
case $$F in \
*.c) echo ' <ClCompile Include="..\..\..\gdk\'$$F'" />' \
;; \
@@ -446,7 +446,7 @@ dist-hook: ../build/win32/vs9/gdk.vcproj ../build/win32/vs10/gdk.vcxproj ../buil
rm libgdk.vs10.sourcefiles
../build/win32/vs10/gdk.vcxproj.filters: ../build/win32/vs10/gdk.vcxproj.filtersin
- for F in $(libgdk_3_la_SOURCES); do \
+ for F in `echo $(libgdk_3_la_SOURCES) | tr '/' '\\'`; do \
case $$F in \
*.c) echo ' <ClCompile Include="..\..\..\gdk\'$$F'"><Filter>Source Files</Filter></ClCompile>' \
;; \