summaryrefslogtreecommitdiff
path: root/gdk-pixbuf/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2004-08-25 16:21:15 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-08-25 16:21:15 +0000
commit17cf070553a025e0dac3206d7019ff52a9a2e8fb (patch)
tree53e8390aee31df5b72b831fe28126e9fb9b4b48e /gdk-pixbuf/Makefile.am
parentf1d9c777fab3688a9f832669a6cdfb3c443d3573 (diff)
downloadgtk+-17cf070553a025e0dac3206d7019ff52a9a2e8fb.tar.gz
Diffstat (limited to 'gdk-pixbuf/Makefile.am')
-rw-r--r--gdk-pixbuf/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gdk-pixbuf/Makefile.am b/gdk-pixbuf/Makefile.am
index 9c370f6328..0ad415ebbe 100644
--- a/gdk-pixbuf/Makefile.am
+++ b/gdk-pixbuf/Makefile.am
@@ -40,10 +40,10 @@ uninstall-ms-lib:
endif
gdk_pixbuf.def: gdk-pixbuf.symbols
- (echo -e EXPORTS; cpp -P -DINCLUDE_VARIABLES gdk-pixbuf.symbols | sed -e '/^$$/d' -e 's/^/\t/') > gdk_pixbuf.def
+ (echo -e EXPORTS; cpp -P -DINCLUDE_VARIABLES $(srcdir)/gdk-pixbuf.symbols | sed -e '/^$$/d' -e 's/^/\t/') > gdk_pixbuf.def
gdk-pixbuf-alias.h: gdk-pixbuf.symbols
- ./makegdkpixbufalias.pl < gdk-pixbuf.symbols > gdk-pixbuf-alias.h
+ ./makegdkpixbufalias.pl < $(srcdir)/gdk-pixbuf.symbols > gdk-pixbuf-alias.h
if OS_UNIX
TESTS = abicheck.sh
@@ -404,7 +404,7 @@ MAINTAINERCLEANFILES += stamp-gdk-pixbuf-marshal.h
# gdk-pixbuf-marshal.c
#
$(srcdir)/gdk-pixbuf-marshal.c: @REBUILD@ $(srcdir)/gdk-pixbuf-marshal.list
- (echo -e "#include \"gdk-pixbuf-alias.h\"" | $(GLIB_GENMARSHAL) --prefix=gdk_pixbuf_marshal $(srcdir)/gdk-pixbuf-marshal.list --body ) >> xgen-gmc \
+ (echo -e "#include \"gdk-pixbuf-alias.h\"" | $(GLIB_GENMARSHAL) --prefix=_gdk_pixbuf_marshal $(srcdir)/gdk-pixbuf-marshal.list --body ) >> xgen-gmc \
&& cp xgen-gmc gdk-pixbuf-marshal.c \
&& rm -f xgen-gmc xgen-gmc~