summaryrefslogtreecommitdiff
path: root/gdk-pixbuf/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-07-09 00:10:12 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-07-09 00:10:12 +0000
commitc0dace5fd9deb9197415ba7c994f392acdfde0ea (patch)
tree14ae690ab3aeab5bdaa9b3da054f8a8b5f37dc6c /gdk-pixbuf/Makefile.am
parent13d49dd3d1981591554262b46e3ab633dd64db75 (diff)
downloadgtk+-c0dace5fd9deb9197415ba7c994f392acdfde0ea.tar.gz
Look for windres on Win32.
2005-07-09 Tor Lillqvist <tml@novell.com> * configure.in: Look for windres on Win32. * gdk-pixbuf/Makefile.am * gdk/win32/rc/Makefile.am * gdk/Makefile.am * gtk/Makefile.am: Don't use the scripts in build/win32 to compile the rc files into resource object files. (This means we lose the build number increment magic, but I doubt it was that useful anyway.) Instead use windres directly. To pass a normal .o file produced by windres through libtool, which would want a .lo file, pass it directly to the linker using a -Wl option. * gdk-pixbuf/gdk_pixbuf.rc.in * gdk/win32/rc/gdk.rc.in * gtk/gtk-win32.rc.in: Replace BUILDNUMBER with 0.
Diffstat (limited to 'gdk-pixbuf/Makefile.am')
-rw-r--r--gdk-pixbuf/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/gdk-pixbuf/Makefile.am b/gdk-pixbuf/Makefile.am
index d038f40eff..1a5de6fc05 100644
--- a/gdk-pixbuf/Makefile.am
+++ b/gdk-pixbuf/Makefile.am
@@ -9,10 +9,11 @@ if OS_WIN32
gdk_pixbuf_def = $(srcdir)/gdk_pixbuf.def
gdk_pixbuf_symbols = -export-symbols $(gdk_pixbuf_def)
-gdk_pixbuf_win32res_lo = gdk_pixbuf-win32res.lo
+gdk_pixbuf_win32_res = gdk_pixbuf-win32-res.o
+gdk_pixbuf_win32_res_ldflag = -Wl,$(gdk_pixbuf_win32_res)
-gdk_pixbuf-win32res.lo : gdk_pixbuf.rc
- $(top_srcdir)/build/win32/lt-compile-resource gdk_pixbuf.rc gdk_pixbuf-win32res.lo
+gdk_pixbuf-win32-res.o : gdk_pixbuf.rc
+ $(WINDRES) gdk_pixbuf.rc $@
install-def-file:
$(INSTALL) $(gdk_pixbuf_def) $(DESTDIR)$(libdir)/gdk_pixbuf-2.0.def
@@ -314,14 +315,15 @@ libgdk_pixbuf_2_0_la_SOURCES = \
gdk-pixbuf-enum-types.c
libgdk_pixbuf_2_0_la_LDFLAGS = \
+ $(gdk_pixbuf_win32_res_ldflag) \
-version-info $(LT_VERSION_INFO) \
$(LIBTOOL_EXPORT_OPTIONS) \
$(no_undefined) \
$(gdk_pixbuf_symbols)
-libgdk_pixbuf_2_0_la_LIBADD = pixops/libpixops.la $(builtin_objs) $(gdk_pixbuf_win32res_lo) $(GDK_PIXBUF_DEP_LIBS)
-libgdk_pixbuf_2_0_la_DEPENDENCIES = pixops/libpixops.la $(builtin_objs) $(gdk_pixbuf_def) $(gdk_pixbuf_win32res_lo)
+libgdk_pixbuf_2_0_la_LIBADD = pixops/libpixops.la $(builtin_objs) $(GDK_PIXBUF_DEP_LIBS)
+libgdk_pixbuf_2_0_la_DEPENDENCIES = pixops/libpixops.la $(builtin_objs) $(gdk_pixbuf_def) $(gdk_pixbuf_win32_res)
gdk_pixbuf_headers = \
gdk-pixbuf.h \