summaryrefslogtreecommitdiff
path: root/gdk-pixbuf/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-01-27 23:17:51 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-01-27 23:17:51 +0000
commit6c616fa84262caccefd00cac2ada5ac29dc16419 (patch)
treec9bd6ddbdf4bfe1773ed4f3843eaad8c9e2504bf /gdk-pixbuf/Makefile.am
parent3804b7e64bb9f0cc88a53f6cc26d3bd03de7d0e9 (diff)
downloadgtk+-6c616fa84262caccefd00cac2ada5ac29dc16419.tar.gz
Rewrite to run on the .la files rather than looking for .so files.
Mon Jan 27 17:10:30 2003 Owen Taylor <otaylor@redhat.com> * Makefile.am (gdk-pixbuf.loaders): Rewrite to run on the .la files rather than looking for .so files. (#102142, Martin Gansser) * Makefile.am: Don't build gdk-pixbuf.loaders when cross-compiling.
Diffstat (limited to 'gdk-pixbuf/Makefile.am')
-rw-r--r--gdk-pixbuf/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gdk-pixbuf/Makefile.am b/gdk-pixbuf/Makefile.am
index 466c95871e..390a70917c 100644
--- a/gdk-pixbuf/Makefile.am
+++ b/gdk-pixbuf/Makefile.am
@@ -433,12 +433,16 @@ install-data-local: install-ms-lib install-libtool-import-lib
echo "***" ; \
fi
+if CROSS_COMPILING
+else
all-local: gdk-pixbuf.loaders
+endif
gdk-pixbuf.loaders: $(loader_LTLIBRARIES) gdk-pixbuf-query-loaders
- if find . -name 'libpixbufloader-*.@SOEXT@' | grep '@SOEXT@' > /dev/null ; then \
+ LOADERS=`echo libpixbufloader-*.la` ; \
+ if test "x$$LOADERS" != 'xlibpixbufloader-*.la' ; then \
echo "Writing a gdk-pixbuf.loader file to use when running examples before installing gdk-pixbuf."; \
- GDK_PIXBUF_MODULEDIR=.libs $(top_builddir)/gdk-pixbuf/gdk-pixbuf-query-loaders > ./gdk-pixbuf.loaders ;\
+ $(top_builddir)/gdk-pixbuf/gdk-pixbuf-query-loaders $$LOADERS > ./gdk-pixbuf.loaders ;\
else \
echo "No dynamic modules found; will use only static modules for uninstalled example programs."; \
touch gdk-pixbuf.loaders; \