summaryrefslogtreecommitdiff
path: root/gdk-pixbuf/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /gdk-pixbuf/Makefile.am
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgtk+-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'gdk-pixbuf/Makefile.am')
-rw-r--r--gdk-pixbuf/Makefile.am128
1 files changed, 64 insertions, 64 deletions
diff --git a/gdk-pixbuf/Makefile.am b/gdk-pixbuf/Makefile.am
index 390a70917c..1031ce8e59 100644
--- a/gdk-pixbuf/Makefile.am
+++ b/gdk-pixbuf/Makefile.am
@@ -238,21 +238,20 @@ builtin_objs = @INCLUDED_LOADER_OBJ@
endif
DEPS = libgdk_pixbuf-$(GTK_API_VERSION).la
-INCLUDES = @STRIP_BEGIN@ \
+INCLUDES = \
-DG_LOG_DOMAIN=\"GdkPixbuf\" \
-I$(top_srcdir) -I$(top_builddir) \
-I$(top_srcdir)/gdk-pixbuf \
-I$(top_builddir)/gdk-pixbuf \
-DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
- -DGTK_VERSION=\"@GTK_VERSION@\" \
- -DGTK_BINARY_VERSION=\"@GTK_BINARY_VERSION@\" \
+ -DGTK_VERSION=\"$(GTK_VERSION)\" \
+ -DGTK_BINARY_VERSION=\"$(GTK_BINARY_VERSION)\" \
-DG_DISABLE_DEPRECATED \
-DGDK_PIXBUF_DISABLE_DEPRECATED \
- @INCLUDED_LOADER_DEFINE@ \
- @GTK_DEBUG_FLAGS@ \
- @GDK_PIXBUF_DEP_CFLAGS@ \
- -DGDK_PIXBUF_ENABLE_BACKEND \
-@STRIP_END@
+ $(INCLUDED_LOADER_DEFINE) \
+ $(GTK_DEBUG_FLAGS) \
+ $(GDK_PIXBUF_DEP_CFLAGS) \
+ -DGDK_PIXBUF_ENABLE_BACKEND
AM_CPPFLAGS = "-DPIXBUF_LIBDIR=\"$(loaderdir)\"" "-DBUILT_MODULES_DIR=\"$(srcdir)/.libs\""
LDADDS = libgdk_pixbuf-$(GTK_API_VERSION).la
@@ -280,7 +279,7 @@ man_MANS = gdk-pixbuf-csource.1
# The GdkPixBuf library
#
libgdk_pixbufincludedir = $(includedir)/gtk-2.0/gdk-pixbuf
-libgdk_pixbuf_2_0_la_SOURCES = @STRIP_BEGIN@ \
+libgdk_pixbuf_2_0_la_SOURCES = \
gdk-pixbuf-i18n.h \
gdk-pixbuf.c \
gdk-pixbuf-animation.c \
@@ -290,14 +289,14 @@ libgdk_pixbuf_2_0_la_SOURCES = @STRIP_BEGIN@ \
gdk-pixbuf-scale.c \
gdk-pixbuf-util.c \
gdk-pixdata.c \
- $(gdk_pixbuf_built_cfiles) \
-@STRIP_END@
-libgdk_pixbuf_2_0_la_LDFLAGS = @STRIP_BEGIN@ \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
- @LIBTOOL_EXPORT_OPTIONS@ \
- $(no_undefined) \
- $(gdk_pixbuf_symbols) \
-@STRIP_END@
+ gdk-pixbuf-enum-types.c
+
+libgdk_pixbuf_2_0_la_LDFLAGS = \
+ -version-info $(LT_VERSION_INFO) \
+ $(LIBTOOL_EXPORT_OPTIONS) \
+ $(no_undefined) \
+ $(gdk_pixbuf_symbols)
+
libgdk_pixbuf_2_0_la_LIBADD = pixops/libpixops.la $(builtin_objs) $(gdk_pixbuf_win32res_lo) $(GDK_PIXBUF_DEP_LIBS)
libgdk_pixbuf_2_0_la_DEPENDENCIES = pixops/libpixops.la $(builtin_objs) $(gdk_pixbuf_def) $(gdk_pixbuf_win32res_lo)
@@ -310,24 +309,27 @@ gdk_pixbuf_headers = \
libgdk_pixbufinclude_HEADERS = \
$(gdk_pixbuf_headers) \
- $(gdk_pixbuf_built_headers) \
+ gdk-pixbuf-enum-types.h \
+ gdk-pixbuf-marshal.h \
gdk-pixbuf-features.h \
gdk-pixdata.h
noinst_HEADERS = \
gdk-pixbuf-private.h
-gdk_pixbuf_built_headers = gdk-pixbuf-enum-types.h gdk-pixbuf-marshal.h
-gdk_pixbuf_built_cfiles = gdk-pixbuf-enum-types.c
-$(libgdk_pixbuf_2_0_la_OBJECTS) $(OBJECTS): $(gdk_pixbuf_built_headers) $(gdk_pixbuf_built_cfiles) gdk-pixbuf-marshal.c
+BUILT_SOURCES = gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.c \
+ gdk-pixbuf-marshal.h gdk-pixbuf-marshal.c
CLEANFILES =
-MAINTAINERCLEANFILES = $(gdk_pixbuf_built_headers) $(gdk_pixbuf_built_cfiles) gdk-pixbuf-marshal.c
+MAINTAINERCLEANFILES = \
+ gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.c \
+ gdk-pixbuf-marshal.h gdk-pixbuf-marshal.c \
+ gdk-pixbuf.loaders
#
# gdk-pixbuf-enum-types.h
#
-$(srcdir)/gdk-pixbuf-enum-types.h: s-enum-types-h
+gdk-pixbuf-enum-types.h: s-enum-types-h
@true
s-enum-types-h: @REBUILD@ $(gdk_pixbuf_headers) Makefile
@@ -337,7 +339,7 @@ s-enum-types-h: @REBUILD@ $(gdk_pixbuf_headers) Makefile
--vhead "GType @enum_name@_get_type (void);\n#define GDK_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
--ftail "G_END_DECLS\n\n#endif /* __GDK_PIXBUF_ENUM_TYPES_H__ */" \
$(gdk_pixbuf_headers) ) > tmp-gdk-pixbuf-enum-types.h \
- && (cmp -s tmp-gdk-pixbuf-enum-types.h $(srcdir)/gdk-pixbuf-enum-types.h || cp tmp-gdk-pixbuf-enum-types.h $(srcdir)/gdk-pixbuf-enum-types.h ) \
+ && (cmp -s tmp-gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.h || cp tmp-gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.h ) \
&& rm -f tmp-gdk-pixbuf-enum-types.h \
&& echo timestamp > $(@F)
@@ -347,30 +349,25 @@ MAINTAINERCLEANFILES += s-enum-types-h
#
# gdk-pixbuf-enum-types.c
#
-$(srcdir)/gdk-pixbuf-enum-types.c: @REBUILD@ $(gdk_pixbuf_headers) Makefile
- cd $(srcdir) && glib-mkenums \
+gdk-pixbuf-enum-types.c: @REBUILD@ $(gdk_pixbuf_headers) Makefile
+ (cd $(srcdir) && glib-mkenums \
--fhead "#include <gdk-pixbuf/gdk-pixbuf.h>" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
--vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
--vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
- $(gdk_pixbuf_headers) > gdk-pixbuf-enum-types.c
+ $(gdk_pixbuf_headers)) > gdk-pixbuf-enum-types.c
#
# gdk-pixbuf-marshal.h
#
-$(srcdir)/gdk-pixbuf-marshal.h: @REBUILD@ stamp-gdk-pixbuf-marshal.h
+gdk-pixbuf-marshal.h: @REBUILD@ stamp-gdk-pixbuf-marshal.h
@true
stamp-gdk-pixbuf-marshal.h: @REBUILD@ $(srcdir)/gdk-pixbuf-marshal.list
- case @GLIB_GENMARSHAL@ in \
- .*) glib_genmarshal=`pwd`/@GLIB_GENMARSHAL@ ;; \
- *) glib_genmarshal=@GLIB_GENMARSHAL@ ;; \
- esac; \
- cd $(srcdir) \
- && $$glib_genmarshal --prefix=gdk_pixbuf_marshal gdk-pixbuf-marshal.list --header >> xgen-gmh \
- && (cmp -s xgen-gmh gdk-pixbuf-marshal.h || cp xgen-gmh gdk-pixbuf-marshal.h) \
- && rm -f xgen-gmh xgen-gmh~ \
+ $(GLIB_GENMARSHAL) --prefix=gdk_pixbuf_marshal $(srcdir)/gdk-pixbuf-marshal.list --header >> xgen-gmh \
+ && (cmp -s xgen-gmh gdk-pixbuf-marshal.h || cp xgen-gmh gdk-pixbuf-marshal.h) \
+ && rm -f xgen-gmh xgen-gmh~ \
&& echo timestamp > $(@F)
CLEANFILES += xgen-gmh
@@ -380,36 +377,38 @@ MAINTAINERCLEANFILES += stamp-gdk-pixbuf-marshal.h
# gdk-pixbuf-marshal.c
#
$(srcdir)/gdk-pixbuf-marshal.c: @REBUILD@ $(srcdir)/gdk-pixbuf-marshal.list
- case @GLIB_GENMARSHAL@ in \
- .*) glib_genmarshal=`pwd`/@GLIB_GENMARSHAL@ ;; \
- *) glib_genmarshal=@GLIB_GENMARSHAL@ ;; \
- esac; \
- cd $(srcdir) \
- && $$glib_genmarshal --prefix=gdk_pixbuf_marshal gdk-pixbuf-marshal.list --body >> xgen-gmc \
- && cp xgen-gmc gdk-pixbuf-marshal.c \
+ $(GLIB_GENMARSHAL) --prefix=gdk_pixbuf_marshal $(srcdir)/gdk-pixbuf-marshal.list --body >> xgen-gmc \
+ && cp xgen-gmc gdk-pixbuf-marshal.c \
&& rm -f xgen-gmc xgen-gmc~
CLEANFILES += xgen-gmc
-EXTRA_DIST = \
- gdk-pixbuf-csource.1 \
- makefile.msc \
- gdk_pixbuf.def \
- gdk_pixbuf.rc \
- gdk-pixbuf-marshal.c \
- gdk-pixbuf-marshal.list \
- pixbufloader_ico.def \
- pixbufloader_ani.def \
- pixbufloader_pnm.def \
- pixbufloader_xpm.def \
- pixbufloader_bmp.def \
- pixbufloader_jpeg.def \
- pixbufloader_ras.def \
- pixbufloader_gif.def \
- pixbufloader_png.def \
- pixbufloader_tiff.def \
- pixbufloader_wbmp.def \
- pixbufloader_xbm.def \
+# if srcdir!=builddir, clean out maintainer-clean files from builddir
+# this allows dist to pass.
+distclean-local:
+ if test $(srcdir) != .; then \
+ rm -f $(MAINTAINERCLEANFILES); \
+ fi
+
+EXTRA_DIST = \
+ gdk-pixbuf-csource.1 \
+ makefile.msc \
+ gdk_pixbuf.def \
+ gdk_pixbuf.rc \
+ gdk-pixbuf-marshal.c \
+ gdk-pixbuf-marshal.list \
+ pixbufloader_ico.def \
+ pixbufloader_ani.def \
+ pixbufloader_pnm.def \
+ pixbufloader_xpm.def \
+ pixbufloader_bmp.def \
+ pixbufloader_jpeg.def \
+ pixbufloader_ras.def \
+ pixbufloader_gif.def \
+ pixbufloader_png.def \
+ pixbufloader_tiff.def \
+ pixbufloader_wbmp.def \
+ pixbufloader_xbm.def \
pixbufloader_tga.def
if CROSS_COMPILING
@@ -433,6 +432,9 @@ install-data-local: install-ms-lib install-libtool-import-lib
echo "***" ; \
fi
+uninstall-local: uninstall-ms-lib uninstall-libtool-import-lib
+ rm -f $(DESTDIR)$(sysconfdir)/gtk-2.0/gdk-pixbuf.loaders
+
if CROSS_COMPILING
else
all-local: gdk-pixbuf.loaders
@@ -448,5 +450,3 @@ gdk-pixbuf.loaders: $(loader_LTLIBRARIES) gdk-pixbuf-query-loaders
touch gdk-pixbuf.loaders; \
fi
-uninstall-local: uninstall-ms-lib uninstall-libtool-import-lib
-