summaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authorTimm Bäder <mail@baedert.org>2016-09-24 09:38:10 +0200
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:52 +0100
commit8ae847e4fcb10ba9731dc33ab65f9c1544c7379e (patch)
tree76f5ab878437629d8725cddc36bef282964b9bd7 /examples/meson.build
parent8bf141b364bbd59d77582644bb423c2d7683774a (diff)
downloadgtk+-8ae847e4fcb10ba9731dc33ab65f9c1544c7379e.tar.gz
Build examples
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build60
1 files changed, 60 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
new file mode 100644
index 0000000000..79af2f8440
--- /dev/null
+++ b/examples/meson.build
@@ -0,0 +1,60 @@
+builder_example = executable(
+ 'builder_example',
+ 'builder.c',
+ dependencies: libgtk_dep
+)
+
+drawing = executable(
+ 'drawing',
+ 'drawing.c',
+ dependencies: libgtk_dep
+)
+
+grid_packing = executable(
+ 'grid-packing',
+ 'grid-packing.c',
+ dependencies: libgtk_dep
+)
+
+hello_world = executable(
+ 'hello-world',
+ 'hello-world.c',
+ dependencies: libgtk_dep
+)
+
+plugman = executable(
+ 'plugman',
+ 'plugman.c',
+ dependencies: libgtk_dep
+)
+
+search_bar = executable(
+ 'search-bar',
+ 'search-bar.c',
+ dependencies: libgtk_dep
+)
+
+sunny = executable(
+ 'sunny',
+ 'sunny.c',
+ dependencies: libgtk_dep
+)
+
+window_default = executable(
+ 'window-default',
+ 'window-default.c',
+ dependencies: libgtk_dep
+)
+
+
+subdir('bp')
+subdir('application1')
+subdir('application2')
+subdir('application3')
+subdir('application4')
+subdir('application5')
+subdir('application6')
+subdir('application7')
+subdir('application8')
+subdir('application9')
+subdir('application10')