summaryrefslogtreecommitdiff
path: root/examples/application2/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-07-20 00:21:48 -0400
committerMatthias Clasen <mclasen@redhat.com>2013-07-20 23:04:47 -0400
commit8087bb7a22303064fef947fc72639fcf70ce1515 (patch)
tree6f27902fc47b4d89f831eeb125a0ede3de1d3d17 /examples/application2/Makefile.am
parent68025551e13eebcd8c610b104d309494a3aa973d (diff)
downloadgtk+-8087bb7a22303064fef947fc72639fcf70ce1515.tar.gz
Add a new example app
Add a new example to the getting started part of the docs. The focus of this example is on 'new stuff': GtkApplication, templates, settings, gmenu, gaction, GtkStack, GtkHeaderBar, GtkSearchBar, GtkRevealer, GtkListBox, GtkMenuButton, etc. It is being developed in several steps. Each step is put in a separate directory below examples/: application1, ..., application8. This is a little repetitive, but lets us use the code of all examples in the documentation.
Diffstat (limited to 'examples/application2/Makefile.am')
-rw-r--r--examples/application2/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/examples/application2/Makefile.am b/examples/application2/Makefile.am
new file mode 100644
index 0000000000..91e3c1903c
--- /dev/null
+++ b/examples/application2/Makefile.am
@@ -0,0 +1,30 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gdk \
+ -I$(top_builddir)/gdk \
+ $(GTK_DEBUG_FLAGS) \
+ $(GTK_DEP_CFLAGS)
+
+LDADD = \
+ $(top_builddir)/gtk/libgtk-3.la \
+ $(top_builddir)/gdk/libgdk-3.la \
+ $(GTK_DEP_LIBS)
+
+
+noinst_PROGRAMS = exampleapp
+
+exampleapp_SOURCES = \
+ main.c \
+ exampleapp.c exampleapp.h \
+ exampleappwin.c exampleappwin.h \
+ resources.c
+
+BUILT_SOURCES = resources.c
+
+resources.c: exampleapp.gresource.xml window.ui
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/exampleapp.gresource.xml \
+ --target=$@ --sourcedir=$(srcdir) --generate-source
+
+EXTRA_DIST = \
+ window.ui \
+ exampleapp.gresource.xml