summaryrefslogtreecommitdiff
path: root/demos/widget-factory/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2015-09-21 20:22:55 +0200
committerBenjamin Otte <otte@redhat.com>2015-09-21 21:58:04 +0200
commit7439a7efda25b0e3acda393a390406c62e4f11af (patch)
treef4e58ab21f258913301ab39d267b15ce67b8360d /demos/widget-factory/Makefile.am
parenta43d5e28b853023745564428d1254dc0b52f086c (diff)
downloadgtk+-7439a7efda25b0e3acda393a390406c62e4f11af.tar.gz
widget-factory: Remove libcanberra support
GTK cannot depend on libcanberra-gtk which depends on GTK. This causes a circular dependency and is especially neat if installed GTK is different enough from uninstalled GTK.
Diffstat (limited to 'demos/widget-factory/Makefile.am')
-rw-r--r--demos/widget-factory/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/demos/widget-factory/Makefile.am b/demos/widget-factory/Makefile.am
index a97b9eac43..bc08f4b143 100644
--- a/demos/widget-factory/Makefile.am
+++ b/demos/widget-factory/Makefile.am
@@ -19,13 +19,13 @@ gtk3_widget_factory_CPPFLAGS = \
-I$(top_srcdir) \
$(GTK_DEBUG_FLAGS) \
$(GTK_DEP_CFLAGS) \
- $(LIBCANBERRA_CFLAGS)
+ $(NULL)
gtk3_widget_factory_LDADD = \
$(top_builddir)/gdk/libgdk-3.la \
$(top_builddir)/gtk/libgtk-3.la \
$(GTK_DEP_LIBS) \
- $(LIBCANBERRA_LIBS)
+ $(NULL)
widget_factory_resources.c: widget-factory.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/widget-factory.gresource.xml)
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<