summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2011-05-26 00:32:31 -0400
committerMatthias Clasen <mclasen@redhat.com>2011-05-26 00:32:31 -0400
commitcf86c7c9bb9710a09c2f9bc8720f9f24c4e3a5e3 (patch)
treedd35572494e8dbda7c1e9ffa14150d914a43dd11 /demos/Makefile.am
parent6499d89a6e39a2842b3281744d9a28cbf6e47d0d (diff)
downloadgtk+-cf86c7c9bb9710a09c2f9bc8720f9f24c4e3a5e3.tar.gz
Move demos around
The pixbuf-demo gets its own subdirectory, the other small tests move from demos/ to tests/.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am55
1 files changed, 1 insertions, 54 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index ad306562f4..254458d6c5 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -1,59 +1,6 @@
## Makefile.am for gtk+/demos
include $(top_srcdir)/Makefile.decl
-SUBDIRS = gtk-demo
-
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_builddir)/gdk \
- -DGDK_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- $(GTK_DEBUG_FLAGS) \
- $(GTK_DEP_CFLAGS)
-
-DEPS = \
- $(top_builddir)/gtk/libgtk-3.la
-
-LDADDS = \
- $(top_builddir)/gtk/libgtk-3.la \
- $(top_builddir)/gdk/libgdk-3.la \
- $(GTK_DEP_LIBS) \
- $(MATH_LIB)
-
-noinst_PROGRAMS = \
- testanimation \
- testpixbuf-color \
- testpixbuf-save \
- testpixbuf-scale \
- pixbuf-demo
-
-testpixbuf_save_DEPENDENCIES = $(DEPS)
-testpixbuf_color_DEPENDENCIES = $(DEPS)
-testpixbuf_scale_DEPENDENCIES = $(DEPS)
-testanimation_DEPENDENCIES = $(DEPS)
-pixbuf_demo_DEPENDENCIES = $(DEPS)
-
-testpixbuf_save_LDADD = $(LDADDS)
-testpixbuf_color_LDADD = $(LDADDS)
-testpixbuf_scale_LDADD = $(LDADDS)
-testanimation_LDADD = $(LDADDS)
-pixbuf_demo_LDADD = $(LDADDS)
-
-testpixbuf_save_SOURCES = testpixbuf-save.c
-testpixbuf_color_SOURCES = testpixbuf-color.c
-testpixbuf_scale_SOURCES = testpixbuf-scale.c
-testanimation_SOURCES = testanimation.c
-pixbuf_demo_SOURCES = pixbuf-demo.c
-
-EXTRA_DIST += \
- apple-red.png \
- background.jpg \
- gnome-applets.png \
- gnome-calendar.png \
- gnome-foot.png \
- gnome-gimp.png \
- gnome-gmush.png \
- gnome-gsame.png \
- gnu-keys.png
+SUBDIRS = gtk-demo pixbuf-demo
-include $(top_srcdir)/git.mk