summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2002-02-16 23:52:30 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2002-02-16 23:52:30 +0000
commitb3d5f148e6c0e2cb688403655c7800b762e33602 (patch)
tree1056439dd24e464adbabc5c374182a886c669345 /demos/Makefile.am
parent554838e4f602d59f5be241d1da188934d51d49c3 (diff)
downloadgtk+-b3d5f148e6c0e2cb688403655c7800b762e33602.tar.gz
More work on #71430.
* examples/*/Makefile (CFLAGS): add deprecation guards. * docs/tutorial/gtk-tut.sgml, examples/*/*.c: make most examples deprecation-clean; the major offenders right now are the examples that make heavy use of completely deprecated or broken widgets: list, tree, text, pixmap, paned and progressbar. These will have to be redone from scratch. * demos/Makefile.am (INCLUDES): add -DGDK_PIXBUF_DISABLE_DEPRECATED.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index 1555c0433d..307b91c6e2 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -7,6 +7,7 @@ INCLUDES = @STRIP_BEGIN@ \
-I$(top_builddir)/gdk \
-DG_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
-DGTK_DISABLE_DEPRECATED \
@GTK_DEBUG_FLAGS@ \
@GTK_DEP_CFLAGS@ \