summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2009-12-19 18:37:39 +0100
committerBenjamin Otte <otte@gnome.org>2009-12-19 18:37:39 +0100
commit9e7c91bf83fd21a559b5658d02a1466deb4de919 (patch)
tree902bdd9c3107a5023bc57190d1cb1b62cb10c464 /demos/Makefile.am
parentff1343a594383e0d88b1aecdf34025dd3ee36ed6 (diff)
downloadgtk+-9e7c91bf83fd21a559b5658d02a1466deb4de919.tar.gz
Fix up linker flags
This adds LDFLAGS everywhere where they were previously pulled in via other libraries. This is however unsupported by modern linkers. You can trigger these failures by building with gold (or, I'm told, with very new ld).
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index 81e07f427a..f87b3cd8b9 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -19,7 +19,9 @@ DEPS = \
LDADDS = \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
$(top_builddir)/gdk/$(gdktargetlib) \
- $(top_builddir)/gtk/$(gtktargetlib)
+ $(top_builddir)/gtk/$(gtktargetlib) \
+ $(GTK_DEP_LIBS) \
+ $(MATH_LIB)
noinst_PROGRAMS = \
testpixbuf-drawable \