summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-09-19 02:10:45 +0000
committerTim Janik <timj@src.gnome.org>2001-09-19 02:10:45 +0000
commit77886cc54081c4e91c66f806e48c29413656d46d (patch)
tree62460417edf2c587bf0b0a94aa670742d4340bf5 /demos/Makefile.am
parent5a43a59ff3f7dd66b43b66c1c38ca4bcb99cd76e (diff)
downloadgtk+-77886cc54081c4e91c66f806e48c29413656d46d.tar.gz
don't use BUILT_SOURCES as its broken in automake 1.4, add explicit object
Wed Sep 19 02:50:40 2001 Tim Janik <timj@gtk.org> * demos/Makefile.am ($(testpixbuf_OBJECTS)): don't use BUILT_SOURCES as its broken in automake 1.4, add explicit object rule to generate this. * gdk-pixbuf/Makefile.am: fix maintainer and normal cleanfiles. get rid of uneccessary stamps, group stuff more logically, and build sources due to object rules. fix srcdir!=builddir.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index 28c0ef6d7c..09131c5aed 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -31,8 +31,6 @@ noinst_PROGRAMS = \
testpixbuf-scale \
pixbuf-demo
-BUILT_SOURCES=test-inline-pixbufs.h
-
test-inline-pixbufs.h: $(top_builddir)/gdk-pixbuf/gdk-pixbuf-csource apple-red.png gnome-foot.png
(topdir=`cd $(top_builddir) && pwd` ; curdir=`pwd` ; \
cd $(srcdir) && \
@@ -55,6 +53,7 @@ testanimation_LDADD = $(LDADDS)
pixbuf_demo_LDADD = $(LDADDS)
testpixbuf_SOURCES = testpixbuf.c pixbuf-init.c
+$(testpixbuf_OBJECTS): test-inline-pixbufs.h
testpixbuf_drawable_SOURCES = testpixbuf-drawable.c pixbuf-init.c
testpixbuf_save_SOURCES = testpixbuf-save.c
testpixbuf_scale_SOURCES = testpixbuf-scale.c pixbuf-init.c