summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-10-04 16:17:29 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-10-04 16:17:29 +0000
commit73e0984242aba198e1e8da425f59acf5c188f69c (patch)
treec868ac48660e5b03ee5cfb54f400a0c9938cbd30 /demos/Makefile.am
parentba768cd33198c997e4b1d170110f97a1f2fb0654 (diff)
downloadgtk+-73e0984242aba198e1e8da425f59acf5c188f69c.tar.gz
Fix envars for uninstalled operation of gdk-pixbuf
Fri Oct 4 12:05:27 2002 Owen Taylor <otaylor@redhat.com> * demos/Makefile.am (pixbuf_csource): Fix envars for uninstalled operation of gdk-pixbuf * demos/Makefile.am (test-inline-pixbufs.h): Remove output on failure.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index a638c60393..3a81a2d1e6 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -35,14 +35,14 @@ noinst_PROGRAMS = \
if CROSS_COMPILING
pixbuf_csource=$(GDK_PIXBUF_CSOURCE)
else
-pixbuf_csource=GDK_PIXBUF_MODULEDIR=$$topdir/gdk-pixbuf/.libs $$topdir/gdk-pixbuf/gdk-pixbuf-csource
+pixbuf_csource=GDK_PIXBUF_MODULE_FILE=$$topdir/gdk-pixbuf/gdk-pixbuf.loaders $$topdir/gdk-pixbuf/gdk-pixbuf-csource
endif
test-inline-pixbufs.h: $(top_builddir)/gdk-pixbuf/gdk-pixbuf-csource apple-red.png gnome-foot.png
(topdir=`cd $(top_builddir) && pwd` ; curdir=`pwd` ; \
cd $(srcdir) && \
$(pixbuf_csource) --build-list \
- apple_red apple-red.png gnome_foot gnome-foot.png >$$curdir/test-inline-pixbufs.h)
+ apple_red apple-red.png gnome_foot gnome-foot.png >$$curdir/test-inline-pixbufs.h || (rm -f $$curdir/test-inline-pixbufs.h && false))
testpixbuf_DEPENDENCIES = $(DEPS)
testpixbuf_drawable_DEPENDENCIES = $(DEPS)