summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-06-21 20:47:22 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-06-21 20:47:22 +0000
commit11056f564b04a956fd3428d7257c839a609fd53e (patch)
treef0ba80f60b9d46230d393b9d39ba132c518da0f0 /demos/Makefile.am
parent443e8c395e9f45d89f669c944366055eead5d021 (diff)
downloadgtk+-11056f564b04a956fd3428d7257c839a609fd53e.tar.gz
Welcome aboard, gdk-pixbuf.
Wed Jun 21 16:38:13 2000 Owen Taylor <otaylor@redhat.com> * gdk-pixbuf/* docs/reference/gdk-pixbuf/*: Welcome aboard, gdk-pixbuf. * gtk/gdk-pixbuf-loader.c (gdk_pixbuf_loader_class_init): fixups for GObject. * gdk/Makefile.am gdk/gdkpixbuf-render.[ch] gdk/gdkpixbuf.[ch]: Bits of gdk-pixbuf with GDK dependencies moved into GDK. * gtk/Makefile.am gtk/gdk-pixbuf-loader.[ch]: Temporarily move gdk-pixbuf-loader here until GObject has signals. * demos/: New directory of demos. Move demos from gdk-pixbuf here. * demos/pixbuf-init.c: Small bit of code to check for loaders in ../gdk-pixbuf/.libs/gdk-pixbuf, and if found, set GDK_PIXBUF_MODULEDIR appropriately. * gdk/gdkcompat.h: Remove GDK_DRAWABLE_PIXMAP compat define which no longer makes sense.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
new file mode 100644
index 0000000000..a0fcc3d673
--- /dev/null
+++ b/demos/Makefile.am
@@ -0,0 +1,58 @@
+## Makefile.am for gtk+/demos
+
+INCLUDES = @STRIP_BEGIN@ \
+ -I$(top_srcdir) \
+ -I$(top_builddir)/gdk-pixbuf \
+ -I$(top_builddir)/gdk \
+ -I$(top_builddir)/gtk \
+ -DGTK_DISABLE_COMPAT_H \
+ @GTK_DEBUG_FLAGS@ \
+ @GTK_XIM_FLAGS@ \
+ @GTK_LOCALE_FLAGS@ \
+ @PANGO_CFLAGS@ \
+ @GLIB_CFLAGS@ \
+ @more_cflags@ \
+@STRIP_END@
+
+DEPS = \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf.la \
+ $(top_builddir)/gdk/@gdktargetlib@ \
+ $(top_builddir)/gtk/@gtktargetlib@
+
+LDADDS = @STRIP_BEGIN@ \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf.la \
+ $(top_builddir)/gdk/@gdktargetlib@ \
+ $(top_builddir)/gtk/@gtktargetlib@ \
+ @more_ldflags@ \
+ @more_libs@ \
+ @GDK_WLIBS@ \
+ @PANGO_LIBS@ \
+ @GLIB_LIBS@ \
+ @GTK_LIBS_EXTRA@ \
+ -lm \
+@STRIP_END@
+
+noinst_PROGRAMS = \
+ testpixbuf \
+ testpixbuf-drawable \
+ testanimation \
+ testpixbuf-scale \
+ pixbuf-demo
+
+testpixbuf_DEPENDENCIES = $(DEPS)
+testpixbuf_drawable_DEPENDENCIES = $(DEPS)
+testpixbuf_scale_DEPENDENCIES = $(DEPS)
+testanimation_DEPENDENCIES = $(DEPS)
+pixbuf_demo_DEPENDENCIES = $(DEPS)
+
+testpixbuf_LDADD = $(LDADDS) -lgmodule
+testpixbuf_drawable_LDADD = $(LDADDS)
+testpixbuf_scale_LDADD = $(LDADDS)
+testanimation_LDADD = $(LDADDS) -lgmodule
+pixbuf_demo_LDADD = $(LDADDS) -lgmodule
+
+testpixbuf_SOURCES = testpixbuf.c pixbuf-init.c
+testpixbuf_drawable_SOURCES = testpixbuf-drawable.c pixbuf-init.c
+testpixbuf_scale_SOURCES = testpixbuf-scale.c pixbuf-init.c
+testanimation_SOURCES = testanimation.c pixbuf-init.c
+pixbuf_demo_SOURCES = pixbuf-demo.c pixbuf-init.c