summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-12-08 23:07:00 -0500
committerMatthias Clasen <mclasen@redhat.com>2010-12-21 12:06:55 -0500
commit07d49ee56a4ce86d9d6154e00ff6b10bd3bdc2a4 (patch)
tree1b90702b472ced7ca391f34df2c110f8d0e6aaa7 /demos/Makefile.am
parentae146a281750926eee6c5fafb88414999ffa6821 (diff)
downloadgtk+-07d49ee56a4ce86d9d6154e00ff6b10bd3bdc2a4.tar.gz
Merge libgdk and libgtk
This commit does a number of things: - remove some dead wchar configury from configure.ac and gdkconfig.h - repurpose gdkconfig.h as header that contains GDK_WINDOWING_foo macros for each included backend, include it in gdk.h and install it in $includedir instead of below $libdir - drop the backend from the library names - build libgdk-3.0.la as a convenience lib and include it in libgtk-3.0.la It does not yet enable building multiple backends at the same time.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index 9fe2ddc33a..efdd0b1183 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -11,14 +11,12 @@ INCLUDES = \
$(GTK_DEBUG_FLAGS) \
$(GTK_DEP_CFLAGS)
-DEPS = \
- $(top_builddir)/gdk/$(gdktargetlib) \
- $(top_builddir)/gtk/$(gtktargetlib)
-
-LDADDS = \
- $(top_builddir)/gdk/$(gdktargetlib) \
- $(top_builddir)/gtk/$(gtktargetlib) \
- $(GTK_DEP_LIBS) \
+DEPS = \
+ $(top_builddir)/gtk/libgtk-3.0.la
+
+LDADDS = \
+ $(top_builddir)/gtk/libgtk-3.0.la \
+ $(GTK_DEP_LIBS) \
$(MATH_LIB)
noinst_PROGRAMS = \