summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@pobox.com>2000-12-06 05:31:30 +0000
committerHavoc Pennington <hp@src.gnome.org>2000-12-06 05:31:30 +0000
commit36aac0177bfe4dfed46cfcf8568256fe5b05f9b0 (patch)
tree5091a09100b1743bf733d47dde7db34e9b673fc6 /configure.in
parent3bc53c742d676a974987ad084f8617a1ab6068fd (diff)
downloadgtk+-36aac0177bfe4dfed46cfcf8568256fe5b05f9b0.tar.gz
add gdkkeys.[hc]
2000-12-03 Havoc Pennington <hp@pobox.com> * gdk/Makefile.am: add gdkkeys.[hc] * gdk/gdkkeys.h, gdk/gdkkeys.c: Move all the keyval stuff to these files from gdk.h, gdk.c; add GdkKeymap type and operations on it. * acconfig.h, configure.in: add checks and command line options for XKB * gdk/x11/gdkkeys-x11.c: Implement the above functions * gdk/x11/gdkevents-x11.c (gdk_event_translate): Put the keycode and group in the key event * gdk/gdkevents.h (struct _GdkEventKey): Add a hardware_keycode field with the low-level hardware key code, and a group field with the keyboard group * gdk/x11/gdkprivate-x11.h: include config.h for HAVE_XKB, and declare a couple globals used for keymap handling * gtk/gtkimcontextsimple.c: Implement ISO 14755 input method, hold down Shift-Control and type a hex number to get a Unicode character corresponding to the hex number (gtk_im_context_simple_get_preedit_string): Fix cursor position (return bytes not chars)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 216702f377..822bbad073 100644
--- a/configure.in
+++ b/configure.in
@@ -112,6 +112,8 @@ AC_ARG_ENABLE(xim, [ --enable-xim support XIM [default=yes]],
, enable_xim="yes")
AC_ARG_ENABLE(xim_inst, [ --disable-xim-inst does not use xim instantiate callback],
, enable_xim_inst="maybe")
+AC_ARG_ENABLE(xkb, [ --enable-xkb support XKB [default=maybe]],
+ , enable_xkb="maybe")
AC_ARG_ENABLE(rebuilds, [ --disable-rebuilds disable all source autogeneration rules],,enable_rebuilds=yes)
AC_ARG_WITH(locale, [ --with-locale=LOCALE locale name you want to use ])
@@ -425,6 +427,20 @@ if test "x$gdktarget" = "xx11"; then
fi
fi
+ # Check for XKB support.
+
+ if test "x$enable_xkb" = "xyes"; then
+ AC_MSG_WARN(XKB support explicitly enabled)
+ AC_DEFINE(HAVE_XKB)
+ elif test "x$enable_xkb" = "xmaybe"; then
+ AC_CHECK_LIB(X11, XkbQueryExtension,
+ AC_DEFINE(HAVE_XKB),
+ ,
+ $x_libs)
+ else
+ AC_MSG_WARN(XKB support explicitly disabled)
+ fi
+
x_cflags="$X_CFLAGS"
x_ldflags="$X_LDFLAGS $X_LIBS"