summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2009-03-01 07:24:28 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2009-03-01 07:24:28 +0000
commitabd5fd2e16e665cbb7abd67e6f3c0758c1613a2c (patch)
treeae7c4c94e3b77212a178a65e931568daf60af620 /configure.in
parent9c017fece2b36531e4a28bc29312e6e623406338 (diff)
downloadgtk+-abd5fd2e16e665cbb7abd67e6f3c0758c1613a2c.tar.gz
Generate po-properties/POTFILES at configure time. Patch by Loïc Minier
* configure.in: Generate po-properties/POTFILES at configure time. Patch by Loïc Minier svn path=/trunk/; revision=22430
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a933ffe998..51bc4331e1 100644
--- a/configure.in
+++ b/configure.in
@@ -504,6 +504,26 @@ AC_OUTPUT_COMMANDS([case "$CONFIG_FILES" in *po-properties/Makefile.in*)
sed -e "/POTFILES =/r po-properties/POTFILES" po-properties/Makefile.in > po-properties/Makefile
esac])
+dnl Snippet below is copied from AM_GLIB_GNU_GETTEXT to generate a first
+dnl po-properties/POTFILES during configure; see GNOME #573515.
+dnl
+dnl Generate list of files to be processed by xgettext which will
+dnl be included in po-properties/Makefile.
+test -d po-properties || mkdir po-properties
+if test "x$srcdir" != "x."; then
+ if test "x`echo $srcdir | sed 's@/.*@@'`" = "x"; then
+ popropsrcprefix="$srcdir/"
+ else
+ popropsrcprefix="../$srcdir/"
+ fi
+else
+ popropsrcprefix="../"
+fi
+rm -f po-properties/POTFILES
+sed -e "/^#/d" -e "/^\$/d" -e "s,.*, $popropsrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \
+< $srcdir/po-properties/POTFILES.in > po-properties/POTFILES
+dnl (End of adapted AM_GLIB_GNU_GETTEXT snippet.)
+
AM_GLIB_DEFINE_LOCALEDIR(GTK_LOCALEDIR)
dnl The DU4 header files don't provide library prototypes unless