summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2007-12-18 13:51:12 +0000
committerChristian Persch <chpe@src.gnome.org>2007-12-18 13:51:12 +0000
commita8e6ee33b1ae23caeb1c21218fb2f2a94d945e08 (patch)
tree4b502b15beed1cd3d8cdb49944453b9d33878898 /configure.in
parentf8a1be3a0401f42f84b83a85a1fb6ac69e6ffd47 (diff)
downloadgtk+-a8e6ee33b1ae23caeb1c21218fb2f2a94d945e08.tar.gz
Integrate gail into gtk+. Bug #169488.
* configure.in: * docs/reference/Makefile.am: * docs/reference/libgail-util/*: * gail-uninstalled.pc.in: * gail.pc.in: * modules/Makefile.am: * modules/other/Makefile.am: * modules/other/gail/*: * modules/other/gail/libgail-util/*: * po/POTFILES.skip: Integrate gail into gtk+. Bug #169488. svn path=/trunk/; revision=19196
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 38 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index fbab5bb3c5..58ea15787e 100644
--- a/configure.in
+++ b/configure.in
@@ -33,7 +33,7 @@ m4_define([gtk_binary_version], [2.10.0])
# required versions of other packages
m4_define([glib_required_version], [2.15.0])
m4_define([pango_required_version], [1.17.3])
-m4_define([atk_required_version], [1.9.0])
+m4_define([atk_required_version], [1.13.0])
m4_define([cairo_required_version], [1.2.0])
@@ -1559,6 +1559,36 @@ AC_SUBST(CAIRO_PREFIX)
AC_SUBST(GTK_DEBUG_FLAGS)
AC_SUBST(GTK_XIM_FLAGS)
+########################
+# Checks needed for gail
+########################
+
+old_LIBS="$LIBS"
+dnl Checks for inet libraries:
+AC_SEARCH_LIBS(gethostent, nsl)
+AC_SEARCH_LIBS(setsockopt, socket)
+AC_SEARCH_LIBS(connect, inet)
+
+dnl check for the sockaddr_un.sun_len member
+AC_CHECK_MEMBER([struct sockaddr_un.sun_len],
+ [struct_sockaddr_un_sun_len=true],
+ [struct_sockaddr_un_suin_len=false],
+ [#include <sys/types.h>
+ #include <sys/un.h>]
+ )
+case $struct_sockaddr_un_sun_len in
+ true)
+ AC_DEFINE_UNQUOTED(HAVE_SOCKADDR_UN_SUN_LEN, 1, Have the sockaddr_un.sun_len member.)
+ ;;
+ *)
+ ;;
+esac
+
+GAIL_INET_LIBS="$LIBS"
+AC_SUBST([GAIL_INET_LIBS])
+
+LIBS="$old_LIBS"
+
################################################################
# Printing system checks
################################################################
@@ -1760,9 +1790,11 @@ gdk-pixbuf-2.0.pc
gdk-2.0.pc
gtk+-2.0.pc
gtk+-unix-print-2.0.pc
+gail.pc
gdk-pixbuf-2.0-uninstalled.pc
gdk-2.0-uninstalled.pc
gtk+-2.0-uninstalled.pc
+gail-uninstalled.pc
m4macros/Makefile
po/Makefile.in
po-properties/Makefile.in
@@ -1778,6 +1810,7 @@ docs/reference/gdk/Makefile
docs/reference/gdk/version.xml
docs/reference/gtk/Makefile
docs/reference/gtk/version.xml
+docs/reference/libgail-util/Makefile
docs/faq/Makefile
docs/tools/Makefile
docs/tutorial/Makefile
@@ -1800,12 +1833,15 @@ gtk/theme-bits/Makefile
gtk/tests/Makefile
gtk/xdgmime/Makefile
modules/Makefile
-modules/input/Makefile
+modules/other/Makefile
+modules/other/gail/Makefile
+modules/other/gail/libgail-util/Makefile
modules/engines/Makefile
modules/engines/pixbuf/Makefile
modules/engines/ms-windows/Makefile
modules/engines/ms-windows/Theme/Makefile
modules/engines/ms-windows/Theme/gtk-2.0/Makefile
+modules/input/Makefile
modules/printbackends/Makefile
modules/printbackends/cups/Makefile
modules/printbackends/lpr/Makefile