summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-29 04:00:45 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-29 04:00:45 +0000
commit6a66c972cafeeabd6e1a35ea7f622bb1f380bb94 (patch)
tree17ac6e6ca176643b755e9b92b24d83075ba27a91 /configure.in
parentcca151bab7ff3f26d0f3b613ce1661dcfe199826 (diff)
downloadgtk+-6a66c972cafeeabd6e1a35ea7f622bb1f380bb94.tar.gz
If major.minor of required and available glib versions are the same, add
2006-01-28 Behdad Esfahbod <behdad@gnome.org> * configure.in: If major.minor of required and available glib versions are the same, add -DG_DISABLE_DEPRECATED to GLIB_CFLAGS. (bug #328617) * */Makefile.am: Remove hardcoded -DG_DISABLE_DEPRECATED.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index beabb8b712..4e786c831f 100644
--- a/configure.in
+++ b/configure.in
@@ -515,6 +515,14 @@ AM_PATH_GLIB_2_0(glib_required_version, :,
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.]),
gobject gmodule-no-export gthread)
+# See if it's safe to turn G_DISABLE_DEPRECATED on.
+GLIB_VERSION_MAJOR_MINOR=`$PKG_CONFIG --modversion glib-2.0 | sed "s/\.@<:@^.@:>@*\$//"`
+GLIB_REQUIRED_VERSION_MAJOR_MINOR=`echo glib_required_version | sed "s/\.@<:@^.@:>@*\$//"`
+if test "x$GLIB_VERSION_MAJOR_MINOR" = "x$GLIB_REQUIRED_VERSION_MAJOR_MINOR"; then
+ CFLAGS="-DG_DISABLE_DEPRECATED $CFLAGS"
+fi
+
+
dnl
dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
dnl