summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-10-04 15:58:19 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-10-04 15:58:19 +0000
commit8555f42715e83e3016fd8a36ee3a99f8d405509f (patch)
tree2305e2ba30fc5f47a6bd52a4d390d130f7f4f1c0 /configure.in
parent85d726f9aa22ff9f6b9487b4f3e380a40f731f4b (diff)
downloadgtk+-8555f42715e83e3016fd8a36ee3a99f8d405509f.tar.gz
Add a check for the Xrandr extension.
Fri Oct 4 11:43:47 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Add a check for the Xrandr extension. * gdk/gdkscreen.[ch]: Add a size-changed signal. * gdk/x11/gdkscreen-x11.[ch]: Patch from Keith packard to hook up ConfigureNotify events on the root window to the ::size-changed signal. (#94560) * gtk/gtkimcontextsimple.c: Warning fixes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d7fba08f53..ab6a3a547a 100644
--- a/configure.in
+++ b/configure.in
@@ -1177,6 +1177,21 @@ if test "x$gdktarget" = "xx11"; then
AM_CONDITIONAL(XINPUT_XFREE, test x$with_xinput = xxfree)
+ # Check for the RANDR extension
+
+ AC_CHECK_LIB(Xrandr, XRRUpdateConfiguration,
+ [AC_CHECK_HEADER(X11/extensions/Xrandr.h,
+ # RANDR requires RENDER
+ if test -z "`echo $x_extra_libs $x_libs | grep "\-lXrender" 2> /dev/null`"; then
+ x_extra_libs="-lXrender $x_extra_libs"
+ fi
+ x_extra_libs="-lXrandr $x_extra_libs"
+ AC_DEFINE(HAVE_RANDR, 1, Have the Xrandr extension library))],
+ :,
+ $X_LIBS -lXrandr -lXrender -lX11 $X_EXTRA_LIBS)
+
+ # Xshm checks
+
if test "x$enable_shm" = "xyes"; then
# Check for shared memory
AC_CHECK_HEADER(sys/ipc.h, AC_DEFINE(HAVE_IPC_H), no_sys_ipc=yes)