summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>1998-09-17 15:40:22 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-09-17 15:40:22 +0000
commit486362db9f47af1f8ef61f4e171965e44c023ab7 (patch)
treee26b357df5fd21f82b61e32c80c2e95fd7bed481 /configure.in
parentee1b96185ff884190a0e44564fb5b36d249ff271 (diff)
downloadgtk+-486362db9f47af1f8ef61f4e171965e44c023ab7.tar.gz
Update to libtool-1.2b, change library versioning scheme to drop
Tue Sep 15 14:57:30 1998 Owen Taylor <otaylor@redhat.com> * Makefile.am gtk-config.in l*: Update to libtool-1.2b, change library versioning scheme to drop LT_RELEASE from the -l line, while keeping it in the soname. Tue Sep 15 14:10:33 1998 Owen Taylor <otaylor@redhat.com> * configure.in Makefile.in: define a MAINT-like variable REBUILD which is set if Perl and awk are found, and autogenerated sources can be rebuilt. Remove the auto-generated sources from CVS. Add dependencies so that the autogenerated sources are rebuilt if the files they depend on change. (This unfortunately currently results in the entire gtk/ directory being rebuilt when any header changes. Moving all enums to gtkenums.h would fix this.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1f3b62ab41..15fb9cfe80 100644
--- a/configure.in
+++ b/configure.in
@@ -107,8 +107,24 @@ if test "x$GCC" = "xyes"; then
fi
fi
-dnl DU4 native cc currently needs -std1 for ANSI mode (instead of K&R)
+# define a MAINT-like variable REBUILD which is set if Perl
+# and awk are found, so autogenerated sources can be rebuilt
+
+AC_PROG_AWK
+AC_CHECK_PROGS(PERL, perl5 perl)
+
+REBUILD=\#
+if test -n "$PERL" && perl -v | grep 'version 5.' > /dev/null ; then
+ if test -n "$AWK" ; then
+ REBUILD=
+ fi
+fi
+AC_SUBST(REBUILD)
+
+dnl The DU4 header files don't provide library prototypes unless
+dnl -std1 is given to the native cc.
AC_MSG_CHECKING([for extra flags to get ANSI library prototypes])
+
gtk_save_LIBS=$LIBS
LIBS="$LIBS -lm"
AC_TRY_RUN([#include <math.h>