summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2009-07-16 20:54:42 -0400
committerMatthias Clasen <mclasen@redhat.com>2009-07-16 20:54:42 -0400
commitc41e36ad8ae2bdff5323d064d28243c0a40afa8e (patch)
treeab6496863eca1f5e506a01b5accb3ee0925b57d8 /configure.in
parent4d282879be83592552441bf5e2eb498dda061b7f (diff)
downloadgtk+-c41e36ad8ae2bdff5323d064d28243c0a40afa8e.tar.gz
Make jasper support optional
To enable it, one must now pass --with-libjasper to configure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e31eea89b9..6acbb49149 100644
--- a/configure.in
+++ b/configure.in
@@ -825,8 +825,8 @@ AC_ARG_WITH(libtiff,
[AC_HELP_STRING([--without-libtiff],
[disable TIFF loader for gdk-pixbuf])])
AC_ARG_WITH(libjasper,
- [AC_HELP_STRING([--without-libjasper],
- [disable JPEG2000 loader for gdk-pixbuf])])
+ [AC_HELP_STRING([--with-libjasper],
+ [enable JPEG2000 loader for gdk-pixbuf])])
AC_ARG_ENABLE(gdiplus,
[AC_HELP_STRING([--enable-gdiplus],
@@ -941,11 +941,11 @@ dnl Test for libpng
fi
dnl Test for libjasper
- if test x$with_libjasper != xno && test -z "$LIBJASPER"; then
+ if test x$with_libjasper = xyes && test -z "$LIBJASPER"; then
AC_CHECK_LIB(jasper, jas_init, LIBJASPER=-ljasper, [], -ljpeg)
fi
- if test x$with_libjasper != xno && test -z "$LIBJASPER"; then
+ if test x$with_libjasper = xyes && test -z "$LIBJASPER"; then
AC_MSG_ERROR([
*** Checks for JPEG2000 loader failed. You can build without it by passing
*** --without-libjasper to configure])