summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2006-06-21 18:16:58 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2006-06-21 18:16:58 +0000
commitbe8f3c72ea1ae469f7f1fa29be40f9e750f9f1ee (patch)
tree63caa243387c7436527c20aaecff9d60df7c156d /configure.in
parenta4290e7000a8144a397720e02022d4d5c9ed0395 (diff)
downloadgtk+-be8f3c72ea1ae469f7f1fa29be40f9e750f9f1ee.tar.gz
Apply a patch by John Palmieri to use buffered io using GIOChannels, clean
2006-06-21 Matthias Clasen <mclasen@redhat.com> Apply a patch by John Palmieri to use buffered io using GIOChannels, clean up error handling and support Cups 1.2 api in the printing code. * acconfig.h: * configure.in: Detect Cups 1.2 * gtk/gtkdebug.h: * gtk/gtkmain.c: Add a printing debug key. * gtk/gtkprintbackend.[hc]: Remove the GError parameter from gtk_print_backend_print_stream, and take a GIOChannel instead of an fd. * gtk/gtkprinter-private.h: * gtk/gtkprinter.c: Replace the fd parameter of _gtk_printer_create_cairo_surface by a GIOChannel. * gtk/gtkprintjob.[hc]: Remove the GError parameter from gtk_print_job_send and make it return void. * gtk/gtkprintoperation-unix.c: * gtk/gtkprintjob.c: Adjust callers, add some debugging support. * modules/printbackends/Makefile.am: Fix DIST_SUBDIRS. * modules/printbackends/cups/Makefile.am: * modules/printbackends/lpr/Makefile.am: Add debug CFLAGS. * modules/printbackends/cups/gtkcupsutils.[hc]: * modules/printbackends/cups/gtkprintbackendcups.c: * modules/printbackends/file/gtkprintbackendfile.c: * modules/printbackends/lpr/gtkprintbackendfile.c: Adapt to the GIOChannel and GError changes, add debug output
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4248eb09d0..b3517760a3 100644
--- a/configure.in
+++ b/configure.in
@@ -1544,6 +1544,17 @@ if test "x$CUPS_CONFIG" != "xno"; then
CUPS_CFLAGS=`cups-config --cflags | sed 's/-O[0-9]*//' | sed 's/-m[^\t]*//g'`
CUPS_LIBS=`cups-config --libs`
+ CUPS_API_VERSION=`cups-config --api-version`
+ CUPS_API_MAJOR=`echo -n $CUPS_API_VERSION | awk -F. '{print $1}'`
+ CUPS_API_MINOR=`echo -n $CUPS_API_VERSION | awk -F. '{print $2}'`
+
+ if test $CUPS_API_MAJOR -gt 1 -o \
+ $CUPS_API_MAJOR -eq 1 -a $CUPS_API_MINOR -ge 2; then
+ AC_DEFINE(HAVE_CUPS_API_1_2)
+ fi
+
+ AC_SUBST(CUPS_API_MAJOR)
+ AC_SUBST(CUPS_API_MINOR)
AC_SUBST(CUPS_CFLAGS)
AC_SUBST(CUPS_LIBS)
fi