summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2006-04-24 07:34:11 +0000
committerAlexander Larsson <alexl@src.gnome.org>2006-04-24 07:34:11 +0000
commit98e12dd91a2e39c441cb29e856fe6de61e51866d (patch)
tree4666d1344ef39c4f844b199edc02bd428225f31f /configure.in
parent2a834a412dbf7ba6f3b28736a92fbf21818c89c1 (diff)
downloadgtk+-98e12dd91a2e39c441cb29e856fe6de61e51866d.tar.gz
Check for cairo-pdf.h. Check for cairo-ps.h on non-win32.
2006-04-24 Alexander Larsson <alexl@redhat.com> * configure.in: Check for cairo-pdf.h. Check for cairo-ps.h on non-win32.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 83b44fe756..857bf9d53d 100644
--- a/configure.in
+++ b/configure.in
@@ -1549,7 +1549,22 @@ if test "x$CUPS_CONFIG" != "xno"; then
fi
AM_CONDITIONAL(HAVE_CUPS, test "x$CUPS_CONFIG" != "xno")
-
+gtk_save_cppflags="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS"
+
+AC_CHECK_HEADER(cairo-pdf.h,,AC_MSG_ERROR([
+*** Can't find cairo-pdf.h. You must build Cairo with the pdf
+*** backend enabled.]))
+
+if test "$os_win32" != "yes"; then
+ AC_CHECK_HEADER(cairo-ps.h,,AC_MSG_ERROR([
+*** Can't find cairo-ps.h. You must build Cairo with the
+*** postscript backend enabled.]))
+fi
+
+CPPFLAGS="$gtk_save_cppflags"
+
+
################################################################
# Strip -export-dynamic from the link lines of various libraries
################################################################