summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Natterer <mitch@gimp.org>2002-05-07 15:53:08 +0000
committerMichael Natterer <mitch@src.gnome.org>2002-05-07 15:53:08 +0000
commit9bff21f5562747da0e4877032a5338865d073a33 (patch)
treee53932bc5f14072e2920cbbd53df50e9d968888f /configure.in
parentcecf4b5c3de41e5784935b36744b843855aa475a (diff)
downloadgtk+-9bff21f5562747da0e4877032a5338865d073a33.tar.gz
added a new conditional CROSS_COMPILING which indicates ($build != $host).
2002-05-07 Michael Natterer <mitch@gimp.org> * configure.in: added a new conditional CROSS_COMPILING which indicates ($build != $host). If it is set, look for gdk-pixbuf-csource in PATH. Error out if it was not found. * gtk/stock-icons/Makefile.am: use the gdk-pixbuf-csource found at configure time if CROSS_COMPILING is set, use the one which was just built otherwise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0ab5f7aef2..40575fb1a7 100644
--- a/configure.in
+++ b/configure.in
@@ -879,6 +879,16 @@ fi
AM_CONDITIONAL(USE_MMX, test x$use_mmx_asm = xyes)
+dnl Look for a host system's gdk-pixbuf-csource if we are cross-compiling
+
+AM_CONDITIONAL(CROSS_COMPILING, test $build != $host)
+
+if test $CROSS_COMPILING; then
+ AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
+ if test x$GDK_PIXBUF_CSOURCE = xno; then
+ AC_MSG_ERROR(Could not find a gdk-pixbuf-csource in your PATH)
+ fi
+fi
GDK_PIXBUF_PACKAGES="gmodule-2.0 gobject-2.0"
GDK_PIXBUF_EXTRA_LIBS="$STATIC_LIB_DEPS $MATH_LIB"