summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2007-01-03 17:55:33 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2007-01-03 17:55:33 +0000
commit5349f6dd8d3cd8c3ed47df8a2c35749ae30c7ecd (patch)
treec1c8c59606f8cb6b05ae4c0bcd51b0dfa130ae82 /configure.in
parent559649c6ff3fec0b115bcd4ec1154141cf0a1f55 (diff)
downloadgtk+-5349f6dd8d3cd8c3ed47df8a2c35749ae30c7ecd.tar.gz
Export SED to make sourcing of libtool work. Tighten up the directfb
2007-01-03 Matthias Clasen <mclasen@redhat.com> * configure.in: Export SED to make sourcing of libtool work. Tighten up the directfb pkgconfig check. svn path=/trunk/; revision=17033
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 9d0aa2653d..2d798d1998 100644
--- a/configure.in
+++ b/configure.in
@@ -366,6 +366,7 @@ AC_ARG_ENABLE(explicit-deps,
AC_MSG_CHECKING([Whether to write dependencies into .pc files])
case $enable_explicit_deps in
auto)
+ export SED
deplibs_check_method=`(./libtool --config; echo 'eval echo $deplibs_check_method') | sh`
if test "x$deplibs_check_method" '!=' xpass_all || test "x$enable_static" = xyes ; then
enable_explicit_deps=yes
@@ -1389,14 +1390,15 @@ if test "x$gdktarget" = "xdirectfb"; then
DIRECTFB_REQUIRED_VERSION=0.9.24
AC_MSG_CHECKING(for DirectFB)
- if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb ; then
+ if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb -a $PKG_CONFIG --exists cairo-directfb ; then
AC_MSG_RESULT(found)
GDK_EXTRA_CFLAGS="`$PKG_CONFIG --cflags cairo-directfb` $GDK_EXTRA_CFLAGS"
GDK_EXTRA_LIBS="`$PKG_CONFIG --libs cairo-directfb` $GDK_EXTRA_LIBS"
else
AC_MSG_ERROR([
-*** DirectFB $DIRECTFB_REQUIRED_VERSION or newer is required. The latest
-*** version of DirectFB is always available from http://www.directfb.org/.
+*** DirectFB $DIRECTFB_REQUIRED_VERSION or newer and the cairo backend
+*** are required. The latest version of DirectFB is always available
+*** from http://www.directfb.org/.
])
fi
@@ -1569,6 +1571,7 @@ CPPFLAGS="$gtk_save_cppflags"
#
# We are using gmodule-no-export now, but I'm leaving the stripping
# code in place for now, since pango and atk still require gmodule.
+export SED
export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
if test -n "$export_dynamic"; then
GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`