summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <maclas@gmx.de>2004-09-15 02:03:58 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-09-15 02:03:58 +0000
commitcb42ec588c4dd9e729eca5efc760ee6e7e4012c1 (patch)
tree80d48513132434e092dac4cd87146bf248f2b3bd /configure.in
parent59207896851a3bc0cb46761d1baab0f478a65edb (diff)
downloadgtk+-cb42ec588c4dd9e729eca5efc760ee6e7e4012c1.tar.gz
New option --disable-visibility to disable the use of ELF visibility
Tue Sep 14 22:01:49 2004 Matthias Clasen <maclas@gmx.de> * configure.in: New option --disable-visibility to disable the use of ELF visibility attributes for PLT reduction. * gtk/makegtkalias.pl: * gdk/makegdkalias.pl: Respect the DISABLE_VISIBILITY define.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 002412466f..b41fa26518 100644
--- a/configure.in
+++ b/configure.in
@@ -48,6 +48,7 @@ AM_CONFIG_HEADER(config.h)
#
# For each of the libraries we build, we define the following
+
# substituted variables:
#
# foo_PACKAGES: pkg-config packages this library requires
@@ -191,6 +192,10 @@ AC_ARG_ENABLE(rebuilds,
[AC_HELP_STRING([--disable-rebuilds],
[disable all source autogeneration rules])],,
[enable_rebuilds=yes])
+AC_ARG_ENABLE(visibility,
+ [AC_HELP_STRING([--disable-visibility],
+ [don't use ELF visibility attributes])],,
+ [enable_visibility=yes])
AC_ARG_WITH(xinput,
[AC_HELP_STRING([--with-xinput=@<:@no/yes@:>@], [support XInput])])
@@ -246,6 +251,11 @@ else
fi
fi
+if test "x$enable_visibility" = "xno"; then
+ GTK_DEBUG_FLAGS="$GTK_DEBUG_FLAGS -DDISABLE_VISIBILITY"
+fi
+
+
AC_DEFINE_UNQUOTED(GTK_COMPILED_WITH_DEBUGGING, "${enable_debug}")