summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /configure.in
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgtk+-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in323
1 files changed, 141 insertions, 182 deletions
diff --git a/configure.in b/configure.in
index b593d9962e..3977eca688 100644
--- a/configure.in
+++ b/configure.in
@@ -1,8 +1,49 @@
-# require autoconf 2.52
-AC_PREREQ(2.52)
-
# Process this file with autoconf to produce a configure script.
-AC_INIT(gdk/gdktypes.h)
+# require autoconf 2.54
+AC_PREREQ(2.54)
+
+# Making releases:
+# GTK_MICRO_VERSION += 1;
+# GTK_INTERFACE_AGE += 1;
+# GTK_BINARY_AGE += 1;
+# if any functions have been added, set GTK_INTERFACE_AGE to 0.
+# if backwards compatibility has been broken,
+# set GTK_BINARY_AGE and GTK_INTERFACE_AGE to 0.
+
+m4_define([gtk_major_version], [2])
+m4_define([gtk_minor_version], [3])
+m4_define([gtk_micro_version], [0])
+m4_define([gtk_version],
+ [gtk_major_version.gtk_minor_version.gtk_micro_version])
+m4_define([gtk_interface_age], [0])
+m4_define([gtk_binary_age], [300])
+# This is the X.Y used in -lgtk-FOO-X.Y
+m4_define([gtk_api_version], [2.0])
+
+# Define a string for the earliest version that this release has
+# forward/backwards binary compatibility with. This is used for module
+# locations. (Should this be backwards-compat instead?)
+#
+#GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
+m4_define([gtk_binary_version], [2.2.0])
+
+# required versions of other packages
+m4_define([glib_required_version], [2.1.4])
+m4_define([pango_required_version], [1.0.1])
+m4_define([atk_required_version], [1.0.1])
+
+
+AC_INIT([gtk+], [gtk_version],
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=gtk+],
+ [gtk+])
+
+AC_CONFIG_SRCDIR([gdk/gdktypes.h])
+
+# Save this value here, since automake will set cflags later
+cflags_set=${CFLAGS+set}
+
+AM_INIT_AUTOMAKE(no-define)
+AM_CONFIG_HEADER(config.h)
#
# For each of the libraries we build, we define the following
@@ -15,31 +56,14 @@ AC_INIT(gdk/gdktypes.h)
# foo_DEP_CFLAGS: All cflags this module requires
-# Save this value here, since automake will set cflags later
-cflags_set=${CFLAGS+set}
-
-dnl we to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
-dnl are available for $ac_help expansion (don't we all *love* autoconf?)
-GLIB_AC_DIVERT_BEFORE_HELP([
-#
-# Making releases:
-# GTK_MICRO_VERSION += 1;
-# GTK_INTERFACE_AGE += 1;
-# GTK_BINARY_AGE += 1;
-# if any functions have been added, set GTK_INTERFACE_AGE to 0.
-# if backwards compatibility has been broken,
-# set GTK_BINARY_AGE and GTK_INTERFACE_AGE to 0.
-#
-GTK_MAJOR_VERSION=2
-GTK_MINOR_VERSION=2
-GTK_MICRO_VERSION=0
-GTK_INTERFACE_AGE=0
-GTK_BINARY_AGE=200
-GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
-dnl This is the X.Y used in -lgtk-FOO-X.Y
-GTK_API_VERSION=2.0
-])dnl
-
+GTK_MAJOR_VERSION=gtk_major_version
+GTK_MINOR_VERSION=gtk_minor_version
+GTK_MICRO_VERSION=gtk_micro_version
+GTK_INTERFACE_AGE=gtk_interface_age
+GTK_BINARY_AGE=gtk_binary_age
+GTK_VERSION=gtk_version
+GTK_API_VERSION=gtk_api_version
+GTK_BINARY_VERSION=gtk_binary_version
AC_SUBST(GTK_MAJOR_VERSION)
AC_SUBST(GTK_MINOR_VERSION)
AC_SUBST(GTK_MICRO_VERSION)
@@ -47,6 +71,7 @@ AC_SUBST(GTK_INTERFACE_AGE)
AC_SUBST(GTK_BINARY_AGE)
AC_SUBST(GTK_API_VERSION)
AC_SUBST(GTK_VERSION)
+AC_SUBST(GTK_BINARY_VERSION)
# libtool versioning
#LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
@@ -55,59 +80,32 @@ AC_SUBST(GTK_VERSION)
#LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
#LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
-LT_RELEASE=$GTK_MAJOR_VERSION.0
-LT_CURRENT=`expr 100 '*' $GTK_MINOR_VERSION + $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
-LT_REVISION=$GTK_INTERFACE_AGE
-LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
-LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
-AC_SUBST(LT_RELEASE)
-AC_SUBST(LT_CURRENT)
-AC_SUBST(LT_REVISION)
-AC_SUBST(LT_AGE)
+m4_define([lt_current], [m4_eval(100 * gtk_minor_version + gtk_micro_version - gtk_interface_age)])
+m4_define([lt_revision], [gtk_interface_age])
+m4_define([lt_age], [m4_eval(gtk_binary_age - gtk_interface_age)])
+LT_VERSION_INFO="lt_current:lt_revision:lt_age"
+LT_CURRENT_MINUS_AGE=m4_eval(lt_current - lt_age)
+AC_SUBST(LT_VERSION_INFO)
AC_SUBST(LT_CURRENT_MINUS_AGE)
-# Define a string for the earliest version that this release has
-# forward/backwards binary compatibility with. This is used for module
-# locations. (Should this be backwards-compat instead?)
-#
-#GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
-GTK_BINARY_VERSION=2.2.0
-AC_SUBST(GTK_BINARY_VERSION)
#
# gdk-pixbuf gets versioned separately, and for now, using standard
# libtool versioning, not GTK+-style versioning
#
-GDK_PIXBUF_MAJOR=$GTK_MAJOR_VERSION
-GDK_PIXBUF_MINOR=$GTK_MINOR_VERSION
-GDK_PIXBUF_MICRO=$GTK_MICRO_VERSION
+GDK_PIXBUF_MAJOR=gtk_major_version
+GDK_PIXBUF_MINOR=gtk_minor_version
+GDK_PIXBUF_MICRO=gtk_micro_version
GDK_PIXBUF_VERSION="${GDK_PIXBUF_MAJOR}.${GDK_PIXBUF_MINOR}.${GDK_PIXBUF_MICRO}"
AC_SUBST(GDK_PIXBUF_MAJOR)
AC_SUBST(GDK_PIXBUF_MINOR)
AC_SUBST(GDK_PIXBUF_MICRO)
AC_SUBST(GDK_PIXBUF_VERSION)
-## Versions of dependencies
-GLIB_REQUIRED_VERSION=2.1.4
-PANGO_REQUIRED_VERSION=1.0.1
-ATK_REQUIRED_VERSION=1.0.1
-
-# For automake.
-VERSION=$GTK_VERSION
-PACKAGE=gtk+
-
GETTEXT_PACKAGE=gtk20
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE")
-# Save this value here, since automake will set cflags later
-cflags_set=${CFLAGS+set}
-
-dnl Initialize automake stuff
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
-
-# Specify a configuration file
-AM_CONFIG_HEADER(config.h)
dnl Initialize libtool
AC_PROG_CC
@@ -115,16 +113,7 @@ AM_DISABLE_STATIC
AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
-dnl XXXX Hack: Set AS and ASFLAGS so that automake 1.5 will be happy
-AS="\${CC}"
-ASFLAGS="\${CFLAGS}"
-AC_SUBST(AS)
-AC_SUBST(ASFLAGS)
-dnl XXXX Hack: Set CCAS and CCASFLAGS so that automake 1.6 will be happy
-CCAS="\${CC}"
-CCASFLAGS="\${CFLAGS}"
-AC_SUBST(CCAS)
-AC_SUBST(CCASFLAGS)
+AM_PROG_AS
dnl Initialize maintainer mode
AM_MAINTAINER_MODE
@@ -162,30 +151,40 @@ if test "$os_win32" = "yes"; then
fi
AM_CONDITIONAL(MS_LIB_AVAILABLE, test x$ms_librarian = xyes)
-dnl figure debugging default, prior to $ac_help setup
-dnl
-GLIB_AC_DIVERT_BEFORE_HELP([
-if test `expr $GTK_MINOR_VERSION \% 2` = 1 ; then
- debug_default=yes
-else
- debug_default=minimum
-fi
-])dnl
+m4_define([debug_default],
+ m4_if(m4_eval(gtk_minor_version % 2), [1], [yes], [minimum]))
dnl declare --enable-* args and collect ac_help strings
-AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
-AC_ARG_ENABLE(shm, [ --enable-shm support shared memory if available [default=yes]],
- echo $enable_shm, enable_shm="yes")
-AC_ARG_ENABLE(ansi, [ --enable-ansi turn on strict ansi [default=no]],
- , enable_ansi=no)
-AC_ARG_ENABLE(xkb, [ --enable-xkb support XKB [default=maybe]],
- , enable_xkb="maybe")
-AC_ARG_ENABLE(rebuilds, [ --disable-rebuilds disable all source autogeneration rules],,enable_rebuilds=yes)
-
-AC_ARG_WITH(xinput, [ --with-xinput=[no/yes] support XInput ])
-
-AC_ARG_WITH(wintab, [ --with-wintab=DIRECTORY use Wintab API with win32 backend])
-AC_ARG_WITH(ie55, [ --with-ie55=DIRECTORY IE5.5 libs and headers (for Active IMM)])
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug=@<:@no/minimum/yes@:>@],
+ [turn on debugging @<:@default=debug_default@:>@]),,
+ enable_debug=debug_default)
+AC_ARG_ENABLE(shm,
+ [AC_HELP_STRING([--enable-shm],
+ [support shared memory if available [default=yes]])],
+ [echo $enable_shm, enable_shm="yes"])
+AC_ARG_ENABLE(ansi,
+ [AC_HELP_STRING([--enable-ansi],
+ [turn on strict ansi [default=no]])],,
+ [enable_ansi=no])
+AC_ARG_ENABLE(xkb,
+ [AC_HELP_STRING([--enable-xkb],
+ [support XKB [default=maybe]])],,
+ [enable_xkb="maybe"])
+AC_ARG_ENABLE(rebuilds,
+ [AC_HELP_STRING([--disable-rebuilds],
+ [disable all source autogeneration rules])],,
+ [enable_rebuilds=yes])
+
+AC_ARG_WITH(xinput,
+ [AC_HELP_STRING([--with-xinput=@<:@no/yes@:>@], [support XInput])])
+
+AC_ARG_WITH(wintab,
+ [AC_HELP_STRING([--with-wintab=DIRECTORY],
+ [use Wintab API with win32 backend])])
+AC_ARG_WITH(ie55,
+ [AC_HELP_STRING([--with-ie55=DIRECTORY],
+ [IE5.5 libs and headers (for Active IMM)])])
GLIB_AC_DIVERT_BEFORE_HELP([
if test "$platform_win32" = yes; then
@@ -210,9 +209,15 @@ gtktargetlib=libgtk-$gdktarget-$GTK_API_VERSION.la
AC_SUBST(gdktargetlib)
AC_SUBST(gtktargetlib)
-AC_ARG_ENABLE(shadowfb, [ --disable-shadowfb disable shadowfb support for linux-fb],,enable_shadowfb=yes)
+AC_ARG_ENABLE(shadowfb,
+ [AC_HELP_STRING([--disable-shadowfb],
+ [disable shadowfb support for linux-fb])],,
+ [enable_shadowfb=yes])
-AC_ARG_ENABLE(fbmanager, [ --enable-fbmanager enable framebuffer manager support (GtkFB)],enable_fbmanager=yes,enable_fbmanager=no)
+AC_ARG_ENABLE(fbmanager,
+ [AC_HELP_STRING([--enable-fbmanager],
+ [enable framebuffer manager support (GtkFB)])],,
+ enable_fbmanager=no)
if test "x$enable_debug" = "xyes"; then
test "$cflags_set" = set || CFLAGS="$CFLAGS -g"
@@ -302,7 +307,10 @@ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
## calls. Oh, also the later pkg-config calls don't include
## the version requirements since those make the module lists
## annoying to construct
-PKG_CHECK_MODULES(BASE_DEPENDENCIES, glib-2.0 >= $GLIB_REQUIRED_VERSION atk >= $ATK_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION)
+PKG_CHECK_MODULES(BASE_DEPENDENCIES,
+ [glib-2.0 >= glib_required_version dnl
+ atk >= atk_required_version dnl
+ pango >= pango_required_version])
if test "$os_win32" != yes; then
# libtool option to control which symbols are exported
@@ -319,9 +327,9 @@ dnl * See whether to include shared library dependencies *
dnl ******************************************************
AC_ARG_ENABLE(explicit-deps,
- [ --enable-explicit-deps=[yes/no/auto] use explicit dependencies in .pc files [default=auto]],
- enable_explicit_deps="$enableval",
- enable_explicit_deps=auto)
+ [AC_HELP_STRING([--enable-explicit-deps=@<:@yes/no/auto@:>@],
+ [use explicit dependencies in .pc files [default=auto]])],,
+ [enable_explicit_deps=auto])
AC_MSG_CHECKING([Whether to write dependencies into .pc files])
case $enable_explicit_deps in
@@ -446,10 +454,10 @@ AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],
GLIB_PACKAGES="gobject-2.0 gmodule-2.0"
-AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION, :,
+AM_PATH_GLIB_2_0(glib_required_version, :,
AC_MSG_ERROR([
-*** GLIB $GLIB_REQUIRED_VERSION or better is required. The latest version of
-*** GLIB is always available from ftp://ftp.gtk.org/.]),
+*** GLIB glib_required_version or better is required. The latest version of
+*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.]),
gobject gmodule gthread)
dnl
@@ -632,7 +640,9 @@ fi
AC_MSG_CHECKING(whether to build gmodulized gdk-pixbuf)
-AC_ARG_ENABLE(modules, [ --disable-modules disable dynamic module loading])
+AC_ARG_ENABLE(modules,
+ [AC_HELP_STRING([--disable-modules],
+ [disable dynamic module loading])])
dynworks=false
deps=
@@ -672,9 +682,15 @@ fi
dnl We allow people to disable image loaders explicitely, but if they don't we error
dnl out so that people don't accidentally build without them.
-AC_ARG_WITH(libpng, [ --without-libpng disable PNG loader for gdk-pixbuf])
-AC_ARG_WITH(libjpeg, [ --without-libjpeg disable JPEG loader for gdk-pixbuf])
-AC_ARG_WITH(libtiff, [ --without-libtiff disable TIFF loader for gdk-pixbuf])
+AC_ARG_WITH(libpng,
+ [AC_HELP_STRING([--without-libpng],
+ [disable PNG loader for gdk-pixbuf])])
+AC_ARG_WITH(libjpeg,
+ [AC_HELP_STRING([--without-libjpeg],
+ [disable JPEG loader for gdk-pixbuf])])
+AC_ARG_WITH(libtiff,
+ [AC_HELP_STRING([--without-libtiff],
+ [disable TIFF loader for gdk-pixbuf])])
dnl Test for libtiff
if test x$with_libtiff != xno && test -z "$LIBTIFF"; then
@@ -793,7 +809,14 @@ AM_CONDITIONAL(BUILD_DYNAMIC_MODULES, $dynworks)
#
AC_MSG_CHECKING(pixbuf loaders to build)
-AC_ARG_WITH(included_loaders, [ --with-included-loaders=LOADER1,LOADER2,... build the specified loaders into gdk-pixbuf (only used if module loading disabled)])
+dnl due to an autoconf bug, commas in the first arg to
+dnl AC_HELP_STRING cause problems.
+dnl AC_HELP_STRING([--with-included-loaders=LOADER1 LOADER2 ...],
+dnl [build the specified loaders into gdk-pixbuf (only used if module loading disabled)])
+AC_ARG_WITH(included_loaders,
+[ --with-included-loaders=LOADER1,LOADER2,...
+ build the specified loaders into gdk-pixbuf (only
+ used if module loading disabled)])
if $dynworks; then
:
@@ -1438,81 +1461,16 @@ AC_SUBST(GTK_XIM_FLAGS)
# Checks for gtk-doc and docbook-tools
##################################################
-AC_ARG_WITH(html-dir, [ --with-html-dir=PATH path to installed docs ])
-
-if test "x$with_html_dir" = "x" ; then
- HTML_DIR='${datadir}/gtk-doc/html'
-else
- HTML_DIR=$with_html_dir
-fi
-
-AC_SUBST(HTML_DIR)
-
-AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
-
-gtk_doc_min_version=0.10
-if $GTKDOC ; then
- gtk_doc_version=`gtkdoc-mkdb --version`
- AC_MSG_CHECKING([gtk-doc version ($gtk_doc_version) >= $gtk_doc_min_version])
-
- IFS="${IFS= }"; gtk_save_IFS="$IFS"; IFS="."
- set $gtk_doc_version
- for min in $gtk_doc_min_version ; do
- cur=$1; shift
- if test -z $min ; then break; fi
- if test -z $cur ; then GTKDOC=false; break; fi
- if test $cur -gt $min ; then break ; fi
- if test $cur -lt $min ; then GTKDOC=false; break ; fi
- done
- IFS="$gtk_save_IFS"
-
- if $GTKDOC ; then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
-fi
+GTK_DOC_CHECK([1.0])
AC_CHECK_PROG(DB2HTML, db2html, true, false)
AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
-dnl Make people enable the gtk-doc stuff explicitely.
-AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc use gtk-doc to build documentation [default=no]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
-
-if test x$enable_gtk_doc = xyes ; then
- if test x$GTKDOC != xtrue ; then
- enable_gtk_doc=no
- fi
-fi
-
-dnl NOTE: We need to use a separate automake conditional for this
-dnl to make this work with the tarballs.
-AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
-
-
##################################################
# Output commands
##################################################
-AC_OUTPUT_COMMANDS([
-
-## Generate `gdk/gdkconfig.h' in two cases
-## 1. `config.status' is run either explicitly, or via configure.
-## Esp. not when it is run in `Makefile' to generate makefiles and
-## config.h
-## 2. CONFIG_OTHER is set explicitly
-##
-## Case 1 is difficult. We know that `automake' sets one of
-## CONFIG_FILES or CONFIG_HEADERS to empty. This heuristic works
-## only when AM_CONFIG_HEADER is set, however.
-
-if test -n "${CONFIG_FILES}" && test -n "${CONFIG_HEADERS}"; then
- # Both CONFIG_FILES and CONFIG_HEADERS are non-empty ==> Case 1
- CONFIG_OTHER=${CONFIG_OTHER:-gdk/gdkconfig.h}
-fi
-case "$CONFIG_OTHER" in
-*gdk/gdkconfig.h*)
- echo creating gdk/gdkconfig.h
+AC_CONFIG_COMMANDS([gdk/gdkconfig.h], [
outfile=gdkconfig.h-tmp
cat > $outfile <<\_______EOF
/* gdkconfig.h
@@ -1545,12 +1503,11 @@ _______EOF
if cmp -s $outfile gdk/gdkconfig.h; then
- echo gdk/gdkconfig.h is unchanged
+ AC_MSG_NOTICE([gdk/gdkconfig.h is unchanged])
rm -f $outfile
else
mv $outfile gdk/gdkconfig.h
- fi ;;
-esac
+ fi
],[
if test "x$gdktarget" = "xx11" ; then
gdk_windowing='
@@ -1583,7 +1540,7 @@ fi
AC_PATH_PROG(SGML2HTML, sgml2html, no)
AM_CONDITIONAL(HAVE_SGML2HTML, test x$SGML2HTML != xno)
-AC_OUTPUT([
+AC_CONFIG_FILES([
config.h.win32
gtk-zip.sh
Makefile
@@ -1634,3 +1591,5 @@ contrib/Makefile
contrib/gdk-pixbuf-xlib/Makefile
contrib/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.0.pc
])
+
+AC_OUTPUT