summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-05-06 13:38:02 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-05-06 13:38:02 +0000
commit4c845c7740e0a23bad1949fbd4efafb31d230ba3 (patch)
treec3acafb8694610a98ec1cfde7945e2cc0af5a57e /configure.in
parent1d66490a5fc02a7f1a77566acdb2952e64c2dcee (diff)
downloadgtk+-4c845c7740e0a23bad1949fbd4efafb31d230ba3.tar.gz
Document the new policy of bumping version numbers after release.
2004-05-06 Matthias Clasen <mclasen@redhat.com> * docs/RELEASE-HOWTO: Document the new policy of bumping version numbers after release. * configure.in: Bump version number to 2.5.0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c498554b33..6273739d0a 100644
--- a/configure.in
+++ b/configure.in
@@ -11,11 +11,11 @@ AC_PREREQ(2.54)
# set GTK_BINARY_AGE and GTK_INTERFACE_AGE to 0.
m4_define([gtk_major_version], [2])
-m4_define([gtk_minor_version], [4])
-m4_define([gtk_micro_version], [1])
+m4_define([gtk_minor_version], [5])
+m4_define([gtk_micro_version], [0])
m4_define([gtk_version],
[gtk_major_version.gtk_minor_version.gtk_micro_version])
-m4_define([gtk_interface_age], [1])
+m4_define([gtk_interface_age], [0])
m4_define([gtk_binary_age],
[m4_eval(100 * gtk_minor_version + gtk_micro_version)])
# This is the X.Y used in -lgtk-FOO-X.Y
@@ -1207,6 +1207,17 @@ if test "x$gdktarget" = "xx11"; then
GDK_EXTRA_CFLAGS="`$PKG_CONFIG --cflags xcursor` $GDK_EXTRA_CFLAGS"
GDK_EXTRA_LIBS="`$PKG_CONFIG --libs xcursor` $GDK_EXTRA_LIBS"
fi
+
+ # Checks for XFixes extension
+
+ have_xfixes=false
+ PKG_CHECK_MODULES(XFIXES, xfixes, have_xfixes=true, :)
+
+ if $have_xfixes ; then
+ AC_DEFINE(HAVE_XFIXES, 1, Have the XFIXES X extension)
+ GDK_EXTRA_CFLAGS="`$PKG_CONFIG --cflags xfixes` $GDK_EXTRA_CFLAGS"
+ GDK_EXTRA_LIBS="`$PKG_CONFIG --libs xfixes` $GDK_EXTRA_LIBS"
+ fi
# Xshm checks