summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-12-20 04:49:49 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-12-20 04:49:49 +0000
commitc7755bc9498b877aedd6a6a7eeb6004c1f134c4e (patch)
tree6f9e340b87349bb03c9f4d97684d651305d493af /configure.in
parentfb14db07bdfb7b0181757c4a0fa33072afc363e7 (diff)
downloadgtk+-c7755bc9498b877aedd6a6a7eeb6004c1f134c4e.tar.gz
Check for FreeType using freetype-config, since we can't rely on Xft to
Tue Dec 19 23:47:27 2000 Owen Taylor <otaylor@redhat.com> * configure.in gdk/x11/Makefile.am: Check for FreeType using freetype-config, since we can't rely on Xft to pull in the libraries for us, or rely on it being in the default include path first. * gtk/gtkframe.c: Fix some problems where the gap wasn't being drawn in the right place, especially for right-aligned frame labels. Thu Dec 14 21:02:59 2000 Owen Taylor <otaylor@redhat.com> * gtk/gtkfontsel.c (gtk_font_selection_select_font): Update the font_name entry as needed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 28 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 5295327e54..6729031a67 100644
--- a/configure.in
+++ b/configure.in
@@ -399,19 +399,39 @@ if test "x$gdktarget" = "xx11"; then
$x_libs)
#
+ # Checks for FreeType
+ #
+ FREETYPE_LIBS=
+ FREETYPE_CFLAGS=
+ have_freetype=false
+ AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+ if test "x$FREE_CONFIG" != "xno" ; then
+ FREETYPE_CFLAGS=`freetype-config --cflags`
+ FREETYPE_LIBS=`freetype-config --libs`
+
+ AC_CHECK_LIB(freetype, FT_New_Face, have_freetype=true
+ ,:,$FREETYPE_LIBS)
+ fi
+ AC_SUBST(FREETYPE_CFLAGS)
+
+ #
# Checks for Xft/XRender
- #
+ #
have_xft=false
XFT_LIBS=""
- AC_CHECK_LIB(Xrender, XRenderFindFormat,
- AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender $X_LIBS)
- ,:,-lXext $X_LIBS)
-
- if $have_xft = 'true' ; then
- X_LIBS="-lXft -lXrender -lXext $X_LIBS"
- AC_DEFINE(HAVE_XFT)
+ XFT_CFLAGS=""
+ if test $have_freetype = true ; then
+ AC_CHECK_LIB(Xrender, XRenderFindFormat,
+ AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender -lXext $X_LIBS $FREETYPE_LIBS)
+ ,:,-lXext $X_LIBS)
+
+ if $have_xft = 'true' ; then
+ X_LIBS="-lXft -lXrender -lXext $FREETYPE_LIBS $X_LIBS"
+ AC_DEFINE(HAVE_XFT)
+ fi
fi
+ AC_SUBST(XFT_LIBS)
AM_CONDITIONAL(HAVE_XFT, $have_xft)
# Check for XIM support.