summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCDT 1999 Shawn T. Amundson <amundson@gtk.org>1999-05-12 08:06:07 +0000
committerShawn Amundson <amundson@src.gnome.org>1999-05-12 08:06:07 +0000
commit45dc3bcf82734647e4e6de1ba01b67dfd02adda8 (patch)
tree8f8b47c989b55e3cfc9e486b1ae9f0570eb9843b /configure.in
parentbf21aecc9144456aa66cb0ebadd974159c23cc9e (diff)
downloadgtk+-45dc3bcf82734647e4e6de1ba01b67dfd02adda8.tar.gz
changes to compile nicely (with xlib) on BeOS
Wed May 12 03:00:56 CDT 1999 Shawn T. Amundson <amundson@gtk.org> * configure.in gtk-config.in ltconfig ltmain.sh gtk/Makefile.am: changes to compile nicely (with xlib) on BeOS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 84e46f9adc..9f6bd513cd 100644
--- a/configure.in
+++ b/configure.in
@@ -196,6 +196,20 @@ AC_TRY_RUN([#include <math.h>
)
LIBS=$gtk_save_LIBS
+MATH_LIB=-lm
+GTK_LIBS_EXTRA=
+AC_MSG_CHECKING(for the BeOS)
+case $host in
+ *-*-beos*)
+ GTK_LIBS_EXTRA="-L\$(top_builddir_full)/gdk/.libs -lgdk"
+ MATH_LIB=
+ ;;
+ default)
+ ;;
+esac
+AC_SUBST(MATH_LIB)
+AC_SUBST(GTK_LIBS_EXTRA)
+
dnl NeXTStep cc seems to need this
AC_MSG_CHECKING([for extra flags for POSIX compliance])
AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],