summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2006-08-29 22:55:31 +0000
committerTor Lillqvist <tml@src.gnome.org>2006-08-29 22:55:31 +0000
commit019fece724f955071fdd1fa12df0409678aabe79 (patch)
treee6946ec815b7eaf820a309bc0142738376acdf0c /configure.in
parentb7d3f4e4a06590f6d6f0c36284e60133a740798d (diff)
downloadgtk+-019fece724f955071fdd1fa12df0409678aabe79.tar.gz
Remove support for Windows 9x/ME. GTK+ hasn't worked on Win9x since 2.6 or
2006-08-29 Tor Lillqvist <tml@novell.com> Remove support for Windows 9x/ME. GTK+ hasn't worked on Win9x since 2.6 or 2.8. It's pointless to keep the Win9x code in here as it isn't being maintained anyway. If somebody is interested, it can always be found in older GTK+ versions, and in CVS. * configure.in * acconfig.h * gdk/Makefile.am * gdk/win32/Makefile.am * gdk/win32/libie55uid.la * gdk/win32/gdkevents-win32.c: Remove the --with-ie55 configure switch and associated stuff. Active IMM and the <dimm.h> header was used for IM support on NT4 and Win9x. Win2k and later have IM support built-in. * gdk/win32/gdkevents-win32.c: Remove the G_WIN32_IS_NT_BASED() and G_WIN32_HAVE_WIDECHAR_API() tests and their false (Win9x) branches, and any variables or static functions used only by the Win9x branches.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 0 insertions, 43 deletions
diff --git a/configure.in b/configure.in
index f8a21c1fdf..2e38a63162 100644
--- a/configure.in
+++ b/configure.in
@@ -214,10 +214,6 @@ AC_ARG_WITH(xinput,
AC_ARG_WITH(wintab,
[AC_HELP_STRING([--with-wintab=DIRECTORY],
[use Wintab API with win32 backend])])
-AC_ARG_WITH(ie55,
- [AC_HELP_STRING([--with-ie55=DIRECTORY],
- [IE5.5 libs and headers (for Active IMM)])])
-
if test "$platform_win32" = yes; then
gdktarget=win32
else
@@ -571,45 +567,6 @@ AC_CHECK_HEADERS(pwd.h, AC_DEFINE(HAVE_PWD_H))
AC_CHECK_HEADERS(sys/time.h, AC_DEFINE(HAVE_SYS_TIME_H))
AC_CHECK_HEADERS(unistd.h, AC_DEFINE(HAVE_UNISTD_H))
-if test "${with_ie55+set}" = set && test $with_ie55 != no; then
- AC_MSG_CHECKING([for dimm.h])
- saved_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -idirafter $with_ie55/Include"
- AC_TRY_COMPILE([/* The w32api imm.h clashes a bit with the IE5.5 dimm.h */
-#ifdef __GNUC__
-#define IMEMENUITEMINFOA hidden_IMEMENUITEMINFOA
-#define IMEMENUITEMINFOW hidden_IMEMENUITEMINFOW
-#endif
-#include <windows.h>
-#include <objbase.h>
-#include <imm.h>
-#ifdef __GNUC__
-#undef IMEMENUITEMINFOA
-#undef IMEMENUITEMINFOW
-#endif
-#include <dimm.h>
-],
- [],
- [AC_MSG_RESULT(yes)
- AC_MSG_CHECKING([for IE55 uuid.lib])
- if test -f $with_ie55/Lib/uuid.lib ; then
- AC_MSG_RESULT(yes)
- have_ie55=yes
- AC_DEFINE(HAVE_DIMM_H)
- IE55_UUID_LIB="$with_ie55/Lib/uuid.lib"
- AC_SUBST(IE55_UUID_LIB)
- else
- AC_MSG_RESULT(no)
- CFLAGS="$saved_CFLAGS"
- have_ie55=no
- fi
- ],
- [AC_MSG_RESULT(no)
- CFLAGS="$saved_CFLAGS"
- have_ie55=no])
-fi
-AM_CONDITIONAL(HAVE_IE55, test x$have_ie55 = xyes)
-
if test "${with_wintab+set}" = set && test $with_wintab != no; then
AC_MSG_CHECKING([for wintab.h])
saved_CFLAGS="$CFLAGS"