summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2001-06-13 21:24:09 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-06-13 21:24:09 +0000
commitb858eb9f59976522592449b40a15e73b2006de57 (patch)
tree3754f6a8c9a4fe1f5786473c88532c3d10180c4d /configure.in
parentb2ff45ef83c94fce1d22885209a92431d7a617fb (diff)
downloadgtk+-b858eb9f59976522592449b40a15e73b2006de57.tar.gz
Updates
2001-06-11 Havoc Pennington <hp@redhat.com> * NEWS: Updates * configure.in (GTK_MINOR_VERSION): bump version to 1.3.6 * gtk/Makefile.am: glib_genmarshal already contains top_builddir
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 20 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index f9d981bb80..f1300ea197 100644
--- a/configure.in
+++ b/configure.in
@@ -34,7 +34,7 @@ AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
#
GTK_MAJOR_VERSION=1
GTK_MINOR_VERSION=3
-GTK_MICRO_VERSION=5
+GTK_MICRO_VERSION=6
GTK_INTERFACE_AGE=0
GTK_BINARY_AGE=0
GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
@@ -655,14 +655,20 @@ if test "x$gdktarget" = "xx11"; then
x_cflags="`$PKG_CONFIG --cflags $PANGO_PACKAGES`"
x_extra_libs=
- if $PKG_CONFIG --uninstalled $PANGO_PACKAGES; then
- :
- else
- # Sanity check for the X11 library
- AC_CHECK_LIB(X11, XOpenDisplay, :,
+ ## Strip the .la files
+
+ x_libs_for_checks=""
+ for I in $x_libs ; do
+ case $I in
+ *.la) ;;
+ *) x_libs_for_checks="$x_libs_for_checks $I" ;;
+ esac
+ done
+
+ # Sanity check for the X11 library
+ AC_CHECK_LIB(X11, XOpenDisplay, :,
AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]),
- $x_libs)
- fi
+ $x_libs_for_checks)
if test "x$enable_shm" = "xyes"; then
# Check for the Xext library (needed for XShm extention)
@@ -676,9 +682,8 @@ if test "x$gdktarget" = "xx11"; then
x_extra_libs="-lXextSam -lXext"
else
x_extra_libs="-lXextSam"
- fi
- no_xext_lib=yes, $x_libs),
- $x_libs)
+ fi, , $x_libs_for_checks),
+ $x_libs_for_checks)
fi
GDK_PIXBUF_XLIB_EXTRA_CFLAGS="$x_cflags"
@@ -693,21 +698,21 @@ if test "x$gdktarget" = "xx11"; then
fi
AC_DEFINE(HAVE_SHAPE_EXT),
,
- $x_libs)
+ $x_libs_for_checks)
# Check for XConvertCase (X11R6 specific)
AC_CHECK_LIB(X11, XConvertCase,
AC_DEFINE(HAVE_XCONVERTCASE),
,
- $x_libs)
+ $x_libs_for_checks)
# Check for XIM support.
AC_CHECK_LIB(X11, XUnregisterIMInstantiateCallback,
: ,
enable_xim_inst="no",
- $x_libs)
+ $x_libs_for_checks)
# On Solaris, calling XRegisterIMInstantiateCallback seems to
# cause an immediate segfault, so we disable it, unless
@@ -740,7 +745,7 @@ if test "x$gdktarget" = "xx11"; then
AC_CHECK_LIB(X11, XkbQueryExtension,
AC_DEFINE(HAVE_XKB),
,
- $x_libs)
+ $x_libs_for_checks)
else
AC_MSG_WARN(XKB support explicitly disabled)
fi